Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

MeX Linux med KDE 4.8, Gnome 3.2, Mate och kernel 3.2.5-mex

Raderat.

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

tux-svens bild

Tack så mycket för den nya kärnan Exton.

Redan installerad med gott resultat på DebEx Mint 10 special.

Headerfilen med GDebi, därefter image-filen med GDebi och en omstart.  Klart!  Laughing out loud

/Sven

---

Windows are for houses, Linux is for computers!

 

extons bild

Ja, ok, men testa också gärna MeX. I den har du ju bl a också Gnome Classic (2.32) och Mate. Dessutom den nya KDE-miljön 4.8, som fungerar utomordentligt bra.

LINUX.EXTON.NET

extons bild

Om Nvidia grafikkort
Jag har installerat Nvidias proprietära grafikdriver 290.10, så att den som har ett nyare Nvidia-kort i datorn kan få njuta av Gnome 3.2-skrivbordet fullt ut under live-körning. PROBLEM: Om du har ett spritt språngande nytt Nvidia-grafikkort som använder OPTIMUS teknik ska du läsa denna artikel. Ytterligare problem med Nvidia: Tyvärr är det så att programfönstren får svart bakgrund i Gnome och Mate om du har ett nyare Nvidia grafikort i din dator. Problemet är detsamma om man loggar in till KDE 4.8 som root. Det spelar ingen roll vilken skrivbordstema som väljs. Problemet är svårt att komma tillrätta med, men jag försöker. Nyssnämnda problem gäller alltså bara er, som har datorer med nyare Nvidia grafikkort. På alla andra datortyper fungerar MeX perfekt (såvitt jag vet). Jag är tacksam för körrapporter. Även tips om hur man kommer tillrätta med de svarta programfönstren mottas tacksamt.

Tillägg lite senare
Det ser ut som om det skulle kunna vara en fråga om minne. D v s grafikkortets minnestilldelning måste ev. maximeras i BIOS. Jag använder själv kortet Nvidia GeForce GTX 550 Ti. Någon som har samma erfarenheter? (Även från någon annan dist än MeX).

LINUX.EXTON.NET

Dom svarta bakgrunderna är en Nvidia bugg enda sättet att få det att fungera är med en äldre Nvidia drivrutin.

Testa 275.43 istället.

http://www.nvidia.com/object/linux-display-amd64-275.43-driver.html

http://www.nvidia.com/object/linux-display-ia32-275.43-driver.html

extons bild

Tack Nille! Jag började (nästan) förtvivla. Nu ska genast testa ditt förslag.

LINUX.EXTON.NET

extons bild

Du räddade min nattsömn. Det fungerade perfekt!

LINUX.EXTON.NET

Det är inte lätt att hålla koll på alla buggar Wink

Sov gott Laughing out loud

extons bild

Den äldre Nvidia drivrutinen fungerar fortfarande alldeles utmärkt på min dator med MeX x32 med bl a KDE 4.8 och grafikkortet Nvidia GeForce GTX 550 Ti. Inga svarta fönster!

En underlighet bra: När jag kör ExTiX 9 x64 med bl a Gnome 3.2 på samma dator fungerar X med den senaste Nvidia drivrutinen 290.10. Inga svarta fönster då heller!

Man skulle kunna tolka det som att Nvidia drivrutinen 290.10 inte går ihop med nya KDE 4.8, men väl med Gnome 3.2. Har du någon tanke om det?

Tillägg lite senare

När jag kör nya PCLinuxOS 2012 på samma dator med KDE 4.6.5 och Nvidia drivrutinen 290.10 installerad får jag heller inga svarta fönster. Stöder min teori om att just KDE 4.8 och 290.10 inte går ihop? Eller att KDE 4.8 i just Ubuntu 11.10 inte går ihop med drivrutinen 290.10?

LINUX.EXTON.NET

Ja den nya Nvidia rutinen buggar med KDE 4.8

Och oftast gäller det endast gtk applikationer.

Om du loggar ut från KDE 4.8 så kommer du få svarta fönter med samtliga VM/DE tills du startar om med senaste Nvidia drivrutinen oavsett dist.

Det är en ren bugg och lär nog åtgärdas i framtida versioner av Nvidia drivrutinen, och tills dess får du använda 275.43 om du använder KDE 4.8

extons bild

Det var som jag misstänkte då mao. Hur som helst är nu MeX [version 120209] helt perfekt (såvitt jag vet). Testa gärna själv så får du se!

LINUX.EXTON.NET

Jag vet inte om buggen är fixad i beta rutinerna med stöd för X.Org Server 1.12 men för den nyfikna användaren så finns 295.17

ftp://download.nvidia.com/XFree86/Linux-x86/295.17/

ftp://download.nvidia.com/XFree86/Linux-x86_64/295.17/

Men det finns ingen orsak att använda dom förutom om man vill testa och ev buggrapportera.

FoHs bild

Den har släppts i skarp version nu: http://www.phoronix.com/scan.php?page=news_item&px=MTA1NzM

Changelog här, men jag kan inte riktigt avgöra om den är fixad: http://www.nvidia.com/object/linux-display-ia32-295.20-driver.html

Tror den är fixad men har inte testat än.

"Fixed a bug that caused black areas to appear on the back faces of some models in Maya."

Såg en annan intressant sak.

"Added a "--no-opengl-files" option to nvidia-installer to allow installation of the driver without OpenGL files that might conflict with already installed OpenGL implementations."

Vilket är bra om du har både intel och nvidia.

Frågan är bara vilka nya buggar/försämringar det med för, för dom har väl bytt ut dom av en orsak.

Kanske första steget för Nvidia att börja använda standard som alla andra grafikdrivrutiner. Smile

Testat 295.20 nu och buggen finns kvar Sad

Men 275.43 fungerar som tur är.