Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

"Unable to find 32bits OpenGL libraries" igen, rätt nu.

Hej igen alla!
Jag tror det blir lite mer text den här gången. Jag får följande meddelande när jag startar PlayOnLinux, "Unable to find 32bits OpenGL libraries". Jag har Mint13-64. Det är en känd bugg, med följand lösning :
(http://www.playonlinux.com/sv/topic-9507-Unable_to_find_32bits_OpenGL_libraries.html
""""""""""""""""""""""""""""""""""""
Had the same problem and fixed it.
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=640499 describes the problem and delivers a patched debian package
First ad multiarch support:dpkg --add-architecture i386
then apt-get install libxv1:i386
dpkg -i libxvmc1_1.0.7-1.1~local_i386.deb (The dowloaded patched version from the debian bugreport
apt-get install libgl1-nvidia-glx:i386
that worked for me
"""""""""""""""""""""""""""""""""

Tyvärr funkar det inte för mig, kan nån hjälpa mig att "översätta" det till Mint?

Bakgrunden är att vissa Nvidia grafikklort bara funkar med Nvidias egna drivare, ej med Ubuntu-varianten. Mitt är ett sådant MSI 560se, det rekommenderas EJ!  Då uppkommer tydligen detta fel, av nåt skäl.

Mycket strul med detta datorprojekt, men lärorikt. Detta är det sista problemet, hoppas jag!Alla med ideer är jättevälkomna.

Tack på förhand MM

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

FoHs bild

Har du även testat med uppdaterade drivrutiner från repos? Numera finns det ju en möjlighet att köra med ett paket som heter nvidia-current-updates. (I nästa version av Ubuntu kommer även beta-drivare finnas med.)

Men om vi ska översätta, vid vilket kommando går det fel och vad säger felmeddelandet i terminalen?

marremuss bild

Hej FoH,

Tack för ditt intresse. FoH. Jag har testat alla de "färdigpaketerade" Nvidiadrivarna, från olika Ubuntu-repon. Inget funkar (för mig, jag har jobbat hårt på det). Googlar man, visar det sig att det finns mycket problem med det grafikkortet. Mindre bra köp! Det enda jag lyckats med, är Nvidias "original" (eller vad man skall säga) drivare, från deras hemsida. 

Jag följer följande tråd, där jag oxo lagt en fråga (som ni ser)
http://www.playonlinux.com/sv/topic-9507-Unable_to_find_32bits_OpenGL_libraries.html

Jag får fel dirrekt i första raden :

oliver@oliver-System-Product-Name ~ $ dpkg --add-architecture i386

dpkg: fel: okänd flagga --add-architecture

Skriv dpkg --help för hjälp om att installera och avinstallera paket [*];
Använd "dselect" eller "aptitude" för användarvänlig pakethantering;
Skriv dpkg -Dhelp för en lista över värden för dpkgs felsökningsflagga;
Skriv dpkg --force-help för en lista över tvingande flaggor;
Skriv dpkg-deb --help för hjälp om manipulering av *.deb-filer;

Flaggor markerade med [*] ger mycket utdata - kör genom "less" eller "more"!
oliver@oliver-System-Product-Name ~ $

Jaha... vad tror du? Finns det hopp?

Fridens

MM

 

 

Ora et Labora

FoHs bild

Testa att hoppa över det första kommandot och kör vidare med de andra. Ubuntu (och därmed Mint) har väl haft multiarch-stöd ett tag nu. Tror du kan installera i386-paketen utan att behöva utöva första kommandot.

marremuss bild

Hej Igen,

* apt-get install libxv1:i386  - OK inga problem, finns redan.

* dpkg -i libxvmc1_1.0.7-1.1~local_i386.deb (The dowloaded patched version from the debian bugreport)
Denna måste referera till : http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=640499
Nu känner jag mig dum. Jag fattar inte VAR i den tråden jag hittar den filen?

Stämmer detta? Så långt kom jag, tror det närmar sig....

 

Tack MM
 
 

 

 

 

Ora et Labora

FoHs bild

Följ länken i sista kommentaren.
Tror inte du kommer kunna installera paketet i det sista kommandot, men testa utan det. Kanske är Debian som paketerar annorlunda (själv har jag bara motsvarande för mesa, nu sitter jag iofs på ett amd-kort i just den här datorn).