Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

Slutet på Linux-problemen med ATI:s grafikkort?

Nu ser det ut som om vi som råkade köpa ATI-grafikkort äntligen kan använda dem utan några problem med installation av proprietära drivrutiner.

Den nya Linux-kärnan 2.6.32 innehåller 3D-drivrutiner för ATI:s 2000, 3000 och 4000 serie av grafikkort.     Äntligen säger jag.   Mycket glädjande.      Laughing out loud

http://www.h-online.com/open/features/What-s-new-in-Linux-2-6-32-872271....

Någon som har provat?

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

FoHs bild

Om jag förstått det rätt kräver det dock rätt versioner av X servern samt Mesa-biblioteket också. Så det blir en del att uppdatera. Men från och med nästa Ubuntu/Mint-version så kommer det förhoppningsvis rulla på fint Smile

tux-svens bild

Säkert, men det är knappast Ubuntu/Mint som har största problemet i dagsläget. Dessa distar installerar ju i alla fall fungerande proprietära drivisar med endast en knapptryckning..    Wink

Fedora 12 har ju nya kärnan, den är som gjord för att testa med avsedd x-org och nyaste mesa.....       Laughing out loud

---

Windows are for houses, Linux is for computers!

 

leochingkwakes bild

Jaha, och vi med andra ATI-kort då? va? va? ;)

benzins bild

Vi får helt enkelt skylla oss själva för att vi köpte fel kort Wink

leochingkwakes bild

Ja, kanske e så. Vet inte hur stödet är för mitt kort dock. Är från 2002 och borde ha hyfsat stöd i alla fall. Men men, kul att det händer nåt även på ATI-sidan.

FoHs bild

leochingkwakes bild

Gäller även ATI Mobility Radeon 7000?

FoHs bild

Ja, bör det göra. Rxxx står alltså för GPUn, och Radeon 7000 verkar tillhöra R100-generationen.

Ja vi med andra/äldre ATI kort kan redan idag njuta av 3D direkt från kärnan.

Och 3D med den öppna rutinen blir bara bättre och bättre för varje release och jag är nöjd med den öppna rutinen i min laptop.

Det enda som saknas just nu är väl energi sparlägen i den öppna rutinen.

Men dom stora förändringarna kommer nog inte att synas i distar förens 2011 men det som finns idag räcker tills dess.

Jag som gillar öppna rutiner är glad att jag har ATI-kort. Smile

jontes bild

Jag har inga problem med 3D och ATI-kort. Jag har läst att många har. Beror det på disten jag har(OpenSuSE 11.2) eller olika kort, -har:

-Rage 128 PCI(ej 3D)

-Radeon 8500 APG

-Radeon 2400 AGP

-Radeon 3200 på MB

-Radeon 3650 AGP

Visst det vore bra om det finns i kärnan och man inte ska behöva slippa djävlas för att få tillgång till 3D funktioner i den egna disten.

-> Allt söder om dalälven kallas för skåne Wink

tux-svens bild

Något är det med ATI-korten - även för Suse.  Jag Googlade på "suse  11.2 problem ATI graphic card" och fick 5220 träffar......

---

Windows are for houses, Linux is for computers!

 

jontes bild

Hmmm.. testade du att lägga till "kernel-sources" vid dina försök? Visst är det sjukt att det ska krångla som sagt för gemene man.

-> Allt söder om dalälven kallas för skåne Wink

Byt ut ati mot nvidia och även då får du över 5000 träffar.

Jag finner nvidia rutinen värre då deras installer skriver över filer i xorg och mesa vilket inte är så bra om du tex byter hårdvara eller vill använda en öppen drivrutin.

Så om du först kört nvidia och byter till tex ett ATI kort så kan du uppleva bekymmer pga att NVIDIA skrivit över filer om du inte installerat om xorg och mesa.

Dom filer som påverkas av nvidias installer är

/usr/lib/libGL.so.1.2
/usr/include/GL/{gl.h glx.h glxext.h glext.h}
/usr/lib/xorg/modules/extensions/{libglx.so libglx.la}

 

Jag har mest ATI och dom fungerar bra.