Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

Kubuntu 64bitars-versionen

Publicerar källor i en kommentar under, hade problem med spamfiltret..

Har något fått Kubuntu/Ubuntu 64 bitars versionenerna till att fungera tillfredsställande?

 

"Det enda problem som jag vet med 64bit-versionen idag är i vissa fall man vill installera något som inte är fritt och open source. Det kan i några få fall idag finnas de som inte tillhandahåller 64bit-versioner av sina program vilket kan skapa problem."

 

 

Jag kunde installera 64 bitars drivrutin för Broadcom trådlösa kortet från och det fungerade. Men varje gång jag startar/startar om datorn måste jag skriva:

sudo rmmod b43
sudo rmmod ssb
sudo modprobe lib80211

Sedan går jag till bibliotek där drivrutin finns och skriver:
sudo insmod wl.ko

 

I 32-bitarsversionen av Ubuntu kunde jag hämta fwcutter för Broadcom firmaware för Linux för att slippa skriva in det här kommandona varje gång jag startar/startar om datorn men det verkade inte fungera för 64 bitars versionen av Kubuntu.

 

Broadcom drivrutin från KpackageKit, Wine och Spotify ljud, Firstclass klient (V. 9.124 (Debian Intel) har jag tyvärr inte att fungera på Kubuntu 9.10 64 bitars version ännu. Har andra haft liknande problem med 64 bitars versionerna av Kubuntu/Ubuntu eller Linux i allmänhet?

 

/ Lyfang

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

Lyfangs bild

Källor:

Första citatet
http://ubuntu-se.org/phpBB3/viewtopic.php?f=208&t=38216

Drivrutinen från Broadcom
www.broadcom.com/support/802.11/linux_sta.php

/ Lyfang

 

Har du läst README filen som tillhör din drivrutin?

http://www.broadcom.com/docs/linux_sta/README.txt

Fråga sedan om det är något du är osäker över.

Lyfangs bild

Det är inte det att jag inte får den att fungera, men att Kubuntu verkar göra så att jag verkar måste göra om lite steg när jag startar eller startar om datorn. Drivrutinen verkar inte laddas automatisk vid uppstart.

Jag tror att den här delen kanske jag inte har fått till, det har jag inte heller fått på 32-bitars version av Ubuntu 9.10, men då finns en firmaware eller drivrutin eller något man kan installera som gör alla steg automatisk. Det hämtade jag via Synaptic på Ubuntu 9.10. Det jag tror det var fwcutter som jag jag installerade på Ubuntu 9.10 32 bitars version som fixade det hela förra gången. Fwcutter verkar inte fungera på Kubuntu 9.10 64 bitars versionen.

Från Broadcoms drivrutinen README.txt:
To blacklist these drivers and prevent them from loading in the future:
# echo "blacklist ssb" >> /etc/modprobe.d/blacklist.conf
# echo "blacklist b43" >> /etc/modprobe.d/blacklist.conf

Har jag provat göra men verkar inte fungera. Skrev:

sudo echo "blacklist ssb" >> /etc/modprobe.d/blacklist.conf

och fick “bash: /etc/modprobe.d/blacklist.conf: Permission denied”

Det hela tror jag löser sig om man kan få följande att laddas automatiskt vid uppstart, det är egentligen det enda, annars fungerar det ju perfekt:

sudo rmmod b43
sudo rmmod ssb
sudo modprobe lib80211

Sedan går jag till bibliotek där drivrutin finns och skriver:
sudo insmod wl.ko

När jag skriver det börjar “wifi knappen” att lysa och det trådlösa nätverkskortet aktiveras och därefter fungerar internet.

/ Lyfang

fredentofts bild

Du får permission denied eftersom du som vanlig användare inte får skriva i den filen. För att skriva till den som root kan du använda:

echo "blacklist ssb" | sudo tee -a  /etc/modprobe.d/blacklist.conf

Visserligen kör du redan med sudo i kommandot du anger, men omdirigeringen ( >> ) görs ändå av din användare.

-
För övrigt anser jag att trådindenteringen måste lagas
-
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

Lyfangs bild

OK, så här blev det efter jag skrev det här och startade om datorn:

sudo echo "blacklist ssb" | sudo tee -a  /etc/modprobe.d/blacklist.conf

sudo echo "blacklist b43" | sudo tee -a  /etc/modprobe.d/blacklist.conf

användarnamn@ubuntu:~$ sudo rmmod b43
[sudo] password for användarnamn:
ERROR: Module b43 does not exist in /proc/modules
användarnamn@ubuntu:~$ sudo rmmod ssb
användarnamn@ubuntu:~$ sudo modprobe lib80211
användarnamn@ubuntu:~$ cd "Bibliotek innehållande wl.ko"/
användarnamn@ubuntu:~/"Bibliotek innehållande wl.ko"$ sudo insmod wl.ko

b43 laddas alltså inte:
ERROR: Module b43 does not exist in /proc/modules

Det väl "bara" det här kvar efter man startar/startar om datorn...
sudo rmmod ssb
sudo modprobe lib80211
cd "Bibliotek innehållande wl.ko"/
sudo insmod wl.ko

/ Lyfang
 

 

 

FoHs bild

Jag funderar lite på om det mer kan vara ett problem med Kubuntu än just arkitekturen. Wine och Spotify fungerar bra för mig på Ubuntu 64-bitars. Är lite osäker på vad jag har för chipset för wlan-korten i mina laptops (vet att det är broadcom på netbooken, men den kör ju 32-bitars) men har inte haft något problem där heller iaf.

Kubuntu får ju i allmänhet inte lika mycket arbete nedlagd på sig.

Lyfangs bild

Kan vara möjligt, t ex så fungerar system ljud vid uppstart men.. idag så gick jag till Youtube och märkte att det inte fanns något ljud. Sedan försökte jag att öppna KMix (ett program för att justera volymen speciellt för KDE) och KMix öppnades inte ens.

/ Lyfang
 

Lyfangs bild

Lyckades intallera Aumix för volumekontroll:

sudo apt-get install aumix-gtk
sudo apt-get install aumix

Fungerade väldigt bra, jag kan höja och sänka volumen på systemljudet. Det var fortfarande problem med att få ljud i Youtube, Firefox, Konqueror spelar ingen roll. Spotify via Wine får inget ljud. För er som planerar att köra med Kubuntu 9.10 64 bitars version så vill jag pga erfarenhet avråda er att använda den då så mycket jag provade inte fungerade. Jag tror att jag ska avinstallera Kubuntu från Windows nu via Wubi avinstalleraren som jag intallerade med och sedan blir det Kubuntu 9.10 32 bitars version istället.

/ Lyfang

Lyfangs bild

Kör med Kubuntu 32 bitars version nu.
"32-bitarsversionen av Ubuntu kunde jag hämta fwcutter för Broadcom firmaware för Linux för att slippa skriva in det här kommandona varje gång jag startar/startar om datorn men det verkade inte fungera för 64 bitars versionen av Kubuntu."

Installerade fwcutter och sen: Applications, System, Hardware Drivers. Activera "Broadcom STA wireless driver" och därefter fungerade trådlösa.

Wine och Spotify ljud, Firstclass klient V. 9.124 (Debian Intel) fungerar på Kubuntu 32 bitars version.

Kanske också går att installera drivrutin på 64-bit på samma sätt, fast inte så van vid KDE ännu. Kan kolla på Youtube klipp med ljud, förrut hade jag ljud fast endast för systemljud, det går att säga att med 32 bitars version gick bättre från start. Vet inte varför inte ljud från andra källor än systemet inte gick att spela upp. Så är nöjd att jag fick det jag ville att fungera att fungera (med Kubuntu). Installationen av svenska och svenska tangentbordslayout gick också bra.

/ Lyfang