Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

Comviq Surf och Huawei E1550 för Ubuntu/Mint info

Hej! 

Jag kör Linux Mint 8 och det är från vad jag vet "Ubuntu" baserat, det blev ett köp av Comviq Surf (kontant) och modemet för Huawei E1550. Det skulle kosta 399:- i butiken med det var kampanj och det blev 299:- som jag tycker var ganska billigt.

OK, skulle installera det och fick det att fungera med Mint så här:

1.

sudo apt-get install usb-modeswitch

2.

http://patas-ubuntu.blogspot.com/2009/05/huawei-3g-modem-e-1550.html

Bocka även "Anslut automatiskt".

3.

Fungerar det? Grattis, eller så får man läsa steg 4

4.

Vet inte om usb-modeswitch behövs egentligen, men hade redan hunnit installera det och det fungerar ju bra än så länge. Skippa steg ett till att börja med om ingen internetanslutningn finns för datorn, annars får man hitta någonstans där man kan "låna" internet eller så får man hämta packeten från en dator med internet med tex. på en USB sticka och installera "manuellt". Då pratar jag endast om usb-modeswitch steg 1 och inte 2.

En annan orsak kan vara att nätet inte fungerar, på Windows mjukvaran fick jag meddelandet: "Error 678:The remote computer did not respond." vilket jag tror har med nätet att göra. Kunde logga in senare dok.

Man kan även se där man har trådlösa anslutningar mm. finns det ”Mobilt bredband” där man kan klicka på Comviq och låta den ansluta(/koppla från), om den inte gör det automatiskt eller inte fungerar av någon anleddning.

/ Lyfang

Edit: Vill tillägga att om man inte får igång internet efter omstart mm. kan finns det en ikon som finns på skrivbordet med namnet "Comviq" som skapas när modemet är i, då kan man högerklicka på ikonen i Mint på "Koppla säkert från enhet", och sedan drar man ut och in modemet så kan man gå in där trådlösa anslutningar finns och sedan välja att ansluta(/koppla från). 

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

bittins bild

Själv undrar jag hur man får den att funka med wvdail :( 

FoHs bild

När enhetsfilen väl dykt upp borde det väl fungera som vilket annat modem som helst, eller?

Lyfangs bild

tux-svens bild

Tackar för informationen Lyfang, nu har jag åxå gjort slag i saken och beställt ett likadant.  Har funderat på detta en tid, så nu var det dags att skrida till handling.  Smile

Det blir perfekt till min nya Asus Aspire One med Mint 8.    Wink

---

Windows are for houses, Linux is for computers!

 

tux-svens bild

Nu har jag fått igång Comviqmodemet på min Acer Aspire One med Linux Mint 8.  Jag provade först lite utan att göra något mer än öppna network managern och Redigera anslutningar, men jag lyckades inte helt.  Jag verkade få igång modemet men det kunde inte kommunicera, det gick inte att få nån trafik över det.

 

Jag betalade då in en veckoavgift för att aktivera det, men inget tycktes hända.  Då lade jag till usb-modeswitch och följde anvisningar enligt "patas" artikel.  Ingen succe´.

 

Jag gjorde ett nytt försök idag.  Det gick igång men jag fick ingen kontakt.  Hmm  då började jag fundera över behörigheter och ändrade mina användarprivilegier.  Allt om modem och internetanslutningar kryssade jag för.

 

Jag provade en gång till, utan lyckat resultat.

 

Då startade jag om maskinen, utan att ha USB-Comviq anslutet.  Därefter stoppade jag i enheten som startade upp och anslöt.  Nu fungerade det utmärkt.   Smile

 

Jag funderade nu var problemet egentligen låg.  Därför startade jag nu upp min gamla eeePC, även den med Linux Mint 8 installerat.

 

Nu gjorde jag ingenting mer än att välja Redigera anslutningar m.h.a Network Managern.  Mobilt -> Sweden -> Comviq/Tele2 -> APN=data.comviq.se.

 

Inget användarnamn eller lösenord.  Jag fyllde endast i PIN eftersom jag ändå hade den tillgänglig. Jag ändrade mina behörigheter även på denna maskin och startade om, utan att ha USB-dongeln i.

 

Då maskinen startat upp stoppade jag i dongeln och Network Managern startade sin söking.  Simsalabim anslöt den till 3g-nätet och fungerade..   Smile

 

Man behöver alltså egentligen inte mecka någonting eller ändra i några filer i Mint 8.

 

Aktivering av värdebevis har jag fullkomligt lagt åt sidan f.n.

EDIT:   Jag kryssade i "anslut automatiskt"  och att det skulle funka för "alla användare" åxå i Network Managern.    Wink

 

---

Windows are for houses, Linux is for computers!

 

Lyfangs bild

Kul att du fick det att fungera till slut.Smile

Lyfangs bild

Nackdelar (just nu)

Spara även ner på hårddisken http://patas-ubuntu.blogspot.com/2009/05/huawei-3g-modem-e-1550.html för att man kan behöva göra om allt har jag märkt.

Andra nackdelar är att den inte verkade vilja hämta hem filer, exempelvis skulle jag ladda hem filen skype-ubuntu-intrepid_2.1.0.47-1_i386.deb men den "orkade" inte ladda hela filen.

Sist kan jag nämna att det inte går som med Windows mjukvaran att köpa ett värdebevis och sedan ladda med mjukvara, vad jag vet i Linux. Men det finns andra alternativ, något av dessa bör fungera med Linux?:

"När du ska tanka ditt kontantkort har du flera olika möjligheter. Du kan tanka via:

- Comviq.se och betala med ditt kontokort. Läs mer här.

- Din Internetbank (Gäller för Swedbank, Nordea, Handelsbanken och SEB). Läs mer här."

Källa: http://www.comviq.se/tankasurf.html

Har uppdaterat Mint med Comviq Surf, det fungerade, surf hastigheten verkade bra och man är inte uppbunden till ett abonnemang heller vilket jag tycker är bra.

/ Lyfang

Edit: 214,6 MB Vista uppdateringar, stannade vid 87%. Försökte att ladda hem Paltalk chattprogram och det gick inte = har inte med Linux att göra. Neddladningar verkar vara ett problem för Comviq Surf. Modemet lyser blått stadigt sken, vilket betyder att modemet är uppkopplad mot 3G. Snabbaste är Turbo 3G står det i Comviqs bruksanvisning.

Tankningen sker väl med AT kommandon om jag inte har helt fel för mig.

Tror nog det finns personer på Comviq som kan svara på vilka som krävs för värdebevisen.

Har du testat att fråga?

Lyfangs bild

Nej, men även om det går så står det:

Minimikrav

USB 2.0 port

Windows 2000 SP4, XP SP2, Vista eller Mac OS X 10.4 och 10.5

 

Källa: http://www.comviq.se/339.html

Så jag vet inte om de har support för Linux. Provade installera Windows mjukvaran med Wine, men det fungerade inte.

Hittade den här sidan: List of AT commands http://www.shapeshifter.se/2008/04/30/list-of-at-commands/

/ Lyfang

Lyfangs bild

Nej, men även om det går så står det:

Minimikrav

USB 2.0 port

Windows 2000 SP4, XP SP2, Vista eller Mac OS X 10.4 och 10.5

 

Källa: http://www.comviq.se/339.html

Så jag vet inte om de har support för Linux. Provade installera Windows mjukvaran med Wine, men det fungerade inte.

Hittade den här sidan: List of AT commands http://www.shapeshifter.se/2008/04/30/list-of-at-commands/

/ Lyfang

Lyfangs bild

Nej, men även om det går så står det:

Minimikrav

USB 2.0 port

Windows 2000 SP4, XP SP2, Vista eller Mac OS X 10.4 och 10.5

 

Källa: http://www.comviq.se/339.html

Så jag vet inte om de har support för Linux. Provade installera Windows mjukvaran med Wine, men det fungerade inte.

Hittade den här sidan: List of AT commands http://www.shapeshifter.se/2008/04/30/list-of-at-commands/

/ Lyfang

Lyfangs bild

Jag tror det hade att göra med Huawei E1550 modemet. Provade Comviq Surf (kontant) med ett Huawei E220 modem och det verkade inte ha några sådana problem.

 

 

 

Lyfangs bild

 Gick inte ladda med Huawei E220 modemet, men gick att byta till Huawei E1550 modemet och göra det.

FoHs bild

Fick anledning att få igång ett Huawei E1750 i Ubuntu 9.04. Förfarandet är väl snartlikt, och så vitt jag kunnat förstått är det i princip samma modem. Följde denna guide och det hoppade igång efter en omstart http://ubuntu-se.org/phpBB3/viewtopic.php?f=223&t=41986&hilit=e1750

Verkar som detta script gör processen automatiskt: http://huaweie1750ubun.sourceforge.net/

Dock fick jag ett 404-felmeddelande när jag körde, i och med att usb_modeswitch nu var i version 1.0.6 så hittades inte filen som enligt guiderna är i version 1.0.2. Då får man naturligtvis editera scriptet eller ladda ned filen manuellt och installera enligt första guiden.

emerains bild

jag kan då berätta att jag as of today har uppdaterat scriptet lite, så den nu använder usb-modeswitch-paketet som finns i ubuntus inbyggda repo

Gott nytt år!

FoHs bild

Trevligt!