Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

[löst] jag får ingen /dev/ttyUSB0

Jag har en GlobalSat DG-100 Datalogger som jag använt i tidigare versioner av openSUSE. Nu har jag uppgraderat till 11.2 men när jag kopplar in GPS:en så får jag ingen /dev/ttyUSB0.

dmesg säger:

[ 9886.546071] usb 3-2: new full speed USB device using uhci_hcd and address 3
[ 9886.688483] usb 3-2: New USB device found, idVendor=067b, idProduct=2303
[ 9886.688510] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 9886.688530] usb 3-2: Product: USB-Serial Controller
[ 9886.688545] usb 3-2: Manufacturer: Prolific Technology Inc.
[ 9886.688810] usb 3-2: configuration #1 chosen from 1 choice
 

och usb-devices säger:

T:  Bus=03 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  3 Spd=12  MxCh= 0
D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1    
P:  Vendor=067b ProdID=2303 Rev= 3.00                           
S:  Manufacturer=Prolific Technology Inc.                       
S:  Product=USB-Serial Controller                               
C:  #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=100mA                          
I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=00 Prot=00 Driver=(none)
 

Den identifieras och enligt alla sökningar (och erfarenhet) så skall den fungera direkt med 2.6-kärnan.

I dmesg borde jag haft en rad som säger ungefär "....PL-2303 converter now attached to ttyUSB0..."

Jag skulle kunnat fråga "Vad kan ha gått fel?" men jag är mer ute efter "Hur får jag den att fungera?". Någon som har ett tips?

/MArtin

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

majos bild

Nu har jag kikat vidare...

modprobe -l usbserial borde ge mig sökvägen till den laddade drivrutinen men modprobe säger bara

FATAL: Could not load /lib/modules/2.6.31.5-0.1-desktop/modules.dep: No such file or directory

Jag har ingen sådan fil/sökväg - den finns under /lib/modules/2.6.31.8-0.1-desktop/modules.dep

Då kikade jag vad modprobe får den sökvägen från och det är från uname -r.

Vad har då blivit galet? Filsystemet har filer i /lib/modules/2.6.31.8-0.1-desktop/modules.dep men mitt system tror att det är 2.6.31.5-0.1-desktop...

/MArtin

majos bild

Och tänk vad en omboot kan göra...

Jag måste ha fått en kernel-uppdatering eler något precis nyss... men ingen uppmaning att logga in på nytt. Allt frid och fröjd! (förutom att jag lärde mig lite under mitt felsökande)

/MArtin