Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

[LÖST] Telias Huawei E1750

 Tja!

Jag fick tag på en ny billig dongel (E1750)från Telia med kontantkort som jag köpte. I W7 fungerar det som det ska utan problem! Men i både min och tjejens Ubuntu-burkar hittar den inte ens dongeln(vid EN uppstart var den hittad och jag kunde surfa utan problem). Den finns med vid "dmesg" och "lsusb" men den finns ej på skrivbordet. 

Googlar man på den modellen så finns det howtos om just denna, fast med "usb_modeswitch". Men på våra datorer finns det ju inget usb_modeswitch kan göra eftersom att datorn inte ens vill montera den som en virtuell cd-rom.

Som jag skrev tidigare så hittade "dattan" dongeln vid EN uppstart(ren tur antar jag), det gick ju att surfa då utan att behöva använda sig av en switch. Så det är nog inte där felet ligger. Jag öppnade "Device manager" vid det tillfället å såg att den var monterad som modell  e260 eller vad det nu var(glömde skriva ner). 

Har ni några förslag på hur jag ska gå tillväga. Jag HAR installerat "usbmount" utan resultat?

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

FoHs bild

Är datorerna fullständigt uppdaterade i övrigt? Huawei-enheter strulade i början med Ubuntu 9.10 nämligen.

usb_modeswitch finns med i paketförrådet, men det är en lite äldre version. Nyaste versionen finns att hämta och kompilera från hemsidan här: http://www.draisberghof.de/usb_modeswitch/

Eller så kanske man kan testa ett deb-paket från Debian, i så fall finns det här: http://packages.debian.org/sid/usb-modeswitch (var försiktig!!)

Men jag har för mig att någon krånglade med detta modem tidigare här på LP, sök på E1550 får du se...

krippas bild

 Som sagt så finns det ju inget som usb_modeswitch kan användas på/mot!!!

Behöver du en erfaren snickare? Kontakta mig på 0735462046 eller maila larssons.byggtjanst@gmail.com

andys bild

Frågan som som föregående ställde, om datorerna är uppdaterade i övrigt, är av yttersta vikt för hur vi ska fortskrida felsökningen.

 

Vad säger /var/log/messages om du kör en tail -f och ansluter modemet?

krippas bild

 Ja, dom är uppdaterade till max

sudo tail -f /var/log/message:

Jan 30 12:07:21  kernel: [   88.630063] usb 2-2: new high speed USB device using ehci_hcd and address 3

Jan 30 12:07:21  kernel: [   88.782617] usb 2-2: configuration #1 chosen from 1 choice

Jan 30 12:07:22  kernel: [   90.097872] Initializing USB Mass Storage driver...

Jan 30 12:07:22  kernel: [   90.098929] scsi5 : SCSI emulation for USB Mass Storage devices

Jan 30 12:07:22  kernel: [   90.099232] scsi6 : SCSI emulation for USB Mass Storage devices

Jan 30 12:07:22  kernel: [   90.099410] usbcore: registered new interface driver usb-storage

Jan 30 12:07:22  kernel: [   90.099418] USB Mass Storage support registered.

Jan 30 12:07:23  usb-modeswitch: switching 12d1:1446 (HUAWEI Technology: HUAWEI Mobile)

Jan 30 12:07:27  kernel: [   95.092090] scsi 6:0:0:0: Direct-Access     HUAWEI   SD Storage       2.31 PQ: 0 ANSI: 2

Jan 30 12:07:27  kernel: [   95.092982] sd 6:0:0:0: Attached scsi generic sg2 type 0

Jan 30 12:07:27 kernel: [   95.099305] sd 6:0:0:0: [sdb] Attached SCSI removable disk

Jan 30 12:07:38  kernel: [  105.340418] sd 6:0:0:0: [sdb] 3842048 512-byte logical blocks: (1.96 GB/1.83 GiB)

Jan 30 12:07:38  kernel: [  105.343585]  sdb: sdb1

 

 

 

Behöver du en erfaren snickare? Kontakta mig på 0735462046 eller maila larssons.byggtjanst@gmail.com

FoHs bild

Verkar som du har usb_modeswitch installerat... eller?

Jan 30 12:07:23  usb-modeswitch: switching 12d1:1446 (HUAWEI Technology: HUAWEI Mobile)

FoHs bild

Klart det finns! Du har väl modemet i datorn? :)

Du verkar anta att det måste dyka upp en ZeroCD-enhet på skrivbordet för att det ska fungera, men så tror jag inte alls fallet är. Det hela sköts ju transparent då du sätter in modemet. Att du inte får upp någon sådan kan ju helt enkelt betyda att modemet varken identifieras som masslagringsenhet eller ZeroCD-enhet.

krippas bild

 Nja, modemet e ju externt, en såndär pinne!

Jo det verkar som att det är installerat, fråga mig inte var det kommer ifrån? Kan inte komma ihåg att jag någon gång har installerat det...Hur som helst så hjälper det ju inte med den switchen...

Behöver du en erfaren snickare? Kontakta mig på 0735462046 eller maila larssons.byggtjanst@gmail.com

andys bild

Vad händer om du skapar en anslutning uppe i hörnet vid klockan. kategori mobilt bredband?

 

Vad säger din dator när du kör kommandot lsusb?

FoHs bild

Och pinnen instoppat i datorn Wink

Det kanske kunde vara värt ett försök med en uppdaterad usb_modeswitch, jag vet inte riktigt. Det är väl 1.0.2 i Ubuntu?

krippas bild

 Äntligen fixat...Jag installerade bara usb-modeswitch med pakethanteraren, samt följde denna länk: http://ubuntu-se.org/phpBB3/viewtopic.php?f=223&t=41986

Hur lätt som helst, krånglade nog till det lite för mycket i vanlig ordning!

Behöver du en erfaren snickare? Kontakta mig på 0735462046 eller maila larssons.byggtjanst@gmail.com