Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

LÖST Startordning Grub2

Hej. Nu har jag dualboot med Windows 7 Home Premium & Linux Mint 8.

Hur ändrar jag som nybörjare startordningen i Grub2 så att datorn startar i Windows som 1:a val?

Min dator är partionerad:
Partition 1 /dev/sda1 Windows 7 Home Premium
Partition 2 /dev/sda2 Linux Mint 8
Partition 3 /dev/sda3 Swap
Partiton 4 /dev/sda4 Lagring

Får följande text om jag klickar på grub i mappen /etc/default:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entrys
#GRUB_DISABLE_LINUX_RECOVERY="true"

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

FoHs bild

Du byter ut GRUB_DEFAULT=0 mot GRUB_DEFAULT="Titeln på det menualternativ som ska vara standard". Om menyalternativet för Windows 7 heter "Windows 7 (loader) (on /dev/sda1)" så skriver du helt enkelt:

GRUB_DEFAULT="Windows 7 (loader) (on /dev/sda1)"

Vill du har utförligare information om GRUB2 hittar du det här: http://www.linuxwiki.se/index.php/Grub2

Edit: Och efter du ändrat filen måste du köra update-grub med root-rättigheter, dvs i en terminal:

sudo update-grub

1Newbes bild

Hej & tack för hjälpen. Följde din tydliga instruktion & tittade även lite på http://www.linuxwiki.se/index.php/Grub2 så nu startar Windows 7 först som jag ville.

 

Får se hur länge det förblir så för Mint känns både modernt, säkert & snabbt för en nybörjare.

Tack än en gång Smile

Många tack!

1Newbe