Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

Ubuntu 9.10 AMD64 och Fel: Fel arkitektur "i386"

Hej! Jag har Ubuntu 9.10 AMD64 och får:

Fel: Fel arkitektur "i386"

Jag gör mitt bästa för hitta 64-bitars program, men går det att installera 32-bitars program på ett bra sätt?

köra med 32-bitars-biblioteken

http://www.linuxportalen.se/node/3939

32-bits dchroot i amd64-bits system

http://www.linuxportalen.se/node/3757

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

FoHs bild

Det är väl inte Flash du försöker installera? (tänker på första länken du postade) Isf är nog 32-bits chroot lite överdrivet då det finns en 64-bitarsversion att få tag i.

Lyfangs bild

Det finns Ubuntu restricted extras för 64-bit. Provar Gnash som finns till 64-bit nu. Det jag vill installera är ett 32-bitars .deb packet.

FoHs bild

Jo, men även Adobe Flash finns i 64-bitarsversion - om det är det du är ute efter? Personligen brukar jag ha problem med den som följer med i paketförrådet och därför installerar jag den som finns på Adobes hemsida. Den tenderar att vara väldigt undangömd... http://labs.adobe.com/downloads/flashplayer10_64bit.html

Om du prompt måste ha programmet i 32-bitsversion så är nog en chroot-miljö alternativet, gissar jag.

Lyfangs bild

Om du installerar i Ubuntu 9.10 AMD64:

sudo apt-get install ubuntu-restricted-extras

Kubuntu:

sudo apt-get install kubuntu-restricted-extras

Adobe Flash Player 10 installerades i Kubuntu 9.10 AMD64 med "sudo apt-get install kubuntu-restricted-extras".

Programmet jag försöker installera heter FirstClass. Filnamnet är fcc-10.009-Linux.i686.deb och fungerar i 32-bitars Kubuntu/Ubuntu.

 Edit: Länken du gav kanske har en nyare Flash Player.

FoHs bild

Det ska vara (ungefär) samma version. Problemet är att den version som installeras via paketförrådet kör med npwrapper, och jag drar då slutsatsen att det rör sig om 32-bitarsversionen av Flash-pluginet. Personligen har jag som sagt haft väldiga problem med den versionen, så jag kör med den jag manuellt laddat ned som är ren 64-bitars. Men det var ju inte Flash du pysslade med tydligen, så det ter sig ju ganska irrelevant Tongue

Angående ditt problem så är det väl chroot som gäller, om du "måste" köra på samma installation. Kompilera själv var ju inget alternativ eftersom det var stängd mjukvara. Har du tänkt på och avfärdat att köra en virtuell maskin för programmet i fråga? Fördelen med Linux är ju att det inte kostar något så att installera en 32-bitarsversion i en virtuell maskin är ju ett alternativ. Personligen hade jag nog kört på det om det var acceptabelt, chroot känns lite besvärligt.

Lyfangs bild

Det är ju bara ett program, så det kanske går med chroot. Andra grejer har jag fått att fungera i 64-bit:

Flash 10 fungerar efter kubuntu-restricted-extras.

Skype gick bra att installera.

Ubuntu 9.10 64-bit och BankID http://www.linuxportalen.se/blogs/foh/2009/11/01/ubuntu-910-64-bit-och-bankid hjälpte mig lite. Har kört detta nyss på Kubuntu 9.10 AMD64:

sudo apt-get install kubuntu-restricted-extras
sudo ./install.4.10.2.16.sh i
nspluginwrapper -i /usr/lib/xulrunner-addons/plugins/libplugins.so
kubuntu-firefox-installer

Det fungerade på Firefox 3.5.8 som installerades med "kubuntu-firefox-installer", men inte på Google Chrome 5.0.307.9 beta AMD64.

Lyfangs bild

Har VirtualBox installerat, men det finns ett alternativ webb login för FirstClass så jag använder det  tills jag hittar ett sätt att installera programmet.

Lyfangs bild

Hur skapar jag en 32-bits chroot-miljö?

Edit: hittade om 32-bits chroot-miljö på: http://www.linuxportalen.se/forums/2009/02/27/64-bits