Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

reparera paket

hej igen

kan nån tala om eller visa hur man reparerar paket i terminalen? jag får nämligen ett meddelande om att jag måste repa paket innan man uppdaterar med uppdateraren .javisstja jag kanske ska tala om att det är linux mint 8 kde som jag kör Smile

mvh bengan

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

tux-svens bild

 Trasiga paket, det är inget vanligt fenomen som jag upplevt det.

Öppna pakethanteraren (Synaptic)

Klicka på "Anpassade filter"

Välj "Trasiga" i listan ovanför.

Nu borde du kunna se vilka paket som är trasiga och kunna ominstallera dem. Smile

---

Windows are for houses, Linux is for computers!

 

bengan2s bild

jag har provat den varianten men den visar inga trasiga paket att laga , men uppdateraren kör inte för det finns trasiga paket att laga först säger den, mystiskt va.

mvh bengan

tux-svens bild

 Det var mystiskt.  Säger uppdateraren något om vilka paket som är trasiga? I så fall skulle du ju bara kunna återinstallera dem.

Det verkar nästan som om det blivit nån inkonsistens i paketdatabasen.  Något liknande läge uppstod för mig när jag spillt kaffe över datorn...  För mig var det slutligen bara att ominstallera OS:et efter att jag rengjort datorn från allt kaffeklägg.

---

Windows are for houses, Linux is for computers!

 

bengan2s bild

nej den talar inte om att nåra paket är trasiga, o nej jag har inte spillt nåt än ere väl bäst o säga lol

extons bild

Kör kommandot sudo apt-get upgrade i terminalen och klistra in felmeddelandena här så vi får se.

LINUX.EXTON.NET

bengan2s bild

Misslyckades med att hämta http://archive.getdeb.net/ubuntu/pool/apps/v/vlc/vlc-nox_1.0.5-1~getdeb1... Kunde inte ansluta till 85.114.135.53:80 (85.114.135.53). - connect (111: Förbindelse vägras)
E: Vissa arkiv kunte inte hämtas. Prova att köra "apt-get update" eller med --fix-missing.

uppdateringen går jäkligt trögt och så får jag dessa felmeddelanden

  Kunde inte ansluta till apt.ubuntu-tw.org http:
Fel http://archive.getdeb.net karmic-getdeb/apps libgimp2.0 2.6.8-1~getdeb1
  Kunde inte ansluta till 85.114.135.53:80 (85.114.135.53). - connect (111: Förbindelse vägras)
Fel http://archive.getdeb.net karmic-getdeb/apps gimp-data 2.6.8-1~getdeb1
  Kunde inte ansluta till apt.ubuntu-tw.org http:
Fel http://archive.getdeb.net karmic-getdeb/apps libpurple-bin 1:2.6.6-1~getdeb2
  Kunde inte ansluta till apt.ubuntu-tw.org http:
Fel http://archive.getdeb.net karmic-getdeb/apps libvlccore2 1.0.5-1~getdeb1
  Kunde inte ansluta till apt.ubuntu-tw.org http:
Fel http://archive.getdeb.net karmic-getdeb/apps libvlc2 1.0.5-1~getdeb1
  Kunde inte ansluta till 85.114.135.53:80 (85.114.135.53). - connect (111: Förbindelse vägras

FoHs bild

Just de där felen verkar ju säga att servern inte går att komma åt för närvarande. Ser att det är paket installerade via Getdeb. Det verkar som jag har samma problem med Getdeb-paket för närvarande.

Edit: Det du skulle kunna göra för att komma runt det är att inaktivera Getdeb-arkivet temporärt. Det kan du göra under System -> Administration -> Mjukvarokällor (Software sources) -> fliken Andra källkor (Other sources) och ta bort bocken vid archive.getdeb.net

Edit2: Ja, och sedan köra sudo apt-get update osv

bengan2s bild

ja det där funkade nu upgraderades utan felmeddelanden,men jag får fortfarande inga trasiga paket i synaptic????+

rolfgubbens bild

Det vanliga rådet är att man kör sudo dpkg --configure -a följt av sudo apt-get install -f i terminalen. Dock är det inte säkert att det fungerar, men du kan ju prova.

bengan2s bild

provadee din variant oxå så här står det

engan@bengan-desktop ~ $ sudo apt-get install -f
Läser paketlistor... Färdig
Bygger beroendeträd
Läser tillståndsinformation... Färdig
Följande paket har installerats automatiskt och är inte längre nödvändiga:
  libpurple0 libsilc-1.1-2 libgstfarsight0.10-0
  libindicate-gtk1 libgssdp-1.0-1 gstreamer0.10-nice
  libgupnp-1.0-2 libpurple-bin libsilcclient-1.1-3
  libzephyr4 libgtkspell0 libnice0 libgupnp-igd-1.0-2
Använd "apt-get autoremove" för att ta bort dem.
0 att uppgradera, 0 att nyinstallera, 0 att ta bort och 132 att inte uppgradera.

bengan

bengan2s bild

nu har jag läst på diverse forum o kommit fram till att den försöker installera kde 4,4 som tydligen har nån bugg, så genom att ta bort kubuntubackports ur programvarukällor så försvann meddelandet om trasiga paket o mitt system e uppdaterat, liten upplysning om nån mer råkar ut för liknande fel

mvh bengan