Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

D-Link DWA-140 hittar inte mitt nätverk

 Hej.

Jag kör med stor glädje Linux Mint 9 x64, Gnome 2.30.00, Kernel 2.6.32-21 generic på en HP DV6-1220SO. Kör dualboot med W7HP(32 bitars) men Mint startar snabbare & fungerar för det mesta snabbare för mig.

Nu till problemet. Datorns inbyggda broadcom kort stöder bara WIFI g så jag har en USB sticka D-Link DWA-140 med N-draft. När jag pluggar in den ser jag 10 trådlösa nätverk men inte mitt eget. Broadcom kortet listar 12...

Jag har gogglat mig grå då många verkar har problem med D-link kortet men inte hittat någon med samma problem.

Har försökt att ansluta med hjälp av nätverksanslutningar både genom att "Skapa nytt..." samt "Anslut till dolt...". Normalt sett sänder inte min router ESSID men jag har provat med & utan den funktionen aktiverad.

I W7 fungerar båda korten samtidigt men inte i Linux. Någon som vet varför? Hur får jag igång den snabbare anslutningen.

När jag fyllt i nätverksnamn & lösenord försöker kortet ansluta men till sist frågar den efter kod igen ( som redan är markerad med asterixer).

Har kört lsusb som ger: ~ $ lsusb

Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 004 Device 002: ID 046d:c510 Logitech, Inc. Cordless Mouse

Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Bus 002 Device 003: ID 5986:0180 Acer, Inc 

Bus 002 Device 002: ID 07d1:3c09 D-Link System DWA-140 802.11n Adapter [ralink rt2870]

Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

 

 

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

FoHs bild

Öppna Loggfilsvisaren (Log File Viewer) och se efter vad daemon.log säger efter att du försökt ansluta. Det är de rader som innehåller NetworkManager och modemmanager som är av intresse.  Kanske kan ge lite ledtrådar på vägen.

Vet du vilken kanal ditt nätverk ligger på? Tänkte om det råkar ligga på den kanal som är aktiverad här i Europa men inte i USA, och modemet (eller drivaren) måste ha en parameter satt för att använda sig av den.

1Newbes bild

Hej. Routern heter Sitecom WL - 341 v1 001  och jag kör

WPA2(AES)Pre-Shared Passphrase samt dold SSID.

Jag har valt kanal 5 som första & kanal 1 som extenssion då det var snabbast i W7. Provade alla kanaler med TPTEST då jag har många trådlösa grannar & tidigare haft mycket strul med Comhem. Har fungerat perfekt i W7 sen den ändringen. Routern sänder B/G/N så att datorns inbyggda kort skall fungera men jag kan manuellt ställa om den till bara N för maximal fart om D-Link adaptern fungerar även i Mint 9.

Klistrar in jättelista från Logfilsvisaren som för mig som nybörjare inte ger mer info än att det inte fungerar på slutet.

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> Activation (wlan0) starting connection 'ComBort'

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> (wlan0): device state change: 3 -> 4 (reason Innocent

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> (wlan0): device state change: 4 -> 5 (reason Innocent

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> Activation (wlan0/wireless): access point 'ComBort' has security, but secrets are required.

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> (wlan0): device state change: 5 -> 6 (reason Innocent

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> (wlan0): device state change: 6 -> 4 (reason Innocent

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> (wlan0): device state change: 4 -> 5 (reason Innocent

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> Activation (wlan0/wireless): connection 'ComBort' has security, and secrets exist. No new secrets needed.

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> Config: added 'ssid' value 'ComBort'

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> Config: added 'scan_ssid' value '1'

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> Config: added 'key_mgmt' value 'WPA-PSK'

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> Config: added 'psk' value '<omitted>'

Jun 1 11:36:51 magnus-laptop NetworkManager: nm_setting_802_1x_get_pkcs11_engine_path: assertion `NM_IS_SETTING_802_1X (setting)' failed

Jun 1 11:36:51 magnus-laptop NetworkManager: nm_setting_802_1x_get_pkcs11_module_path: assertion `NM_IS_SETTING_802_1X (setting)' failed

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> Config: set interface ap_scan to 1

Jun 1 11:36:51 magnus-laptop NetworkManager: <info> (wlan0): supplicant connection state: inactive -> scanning

Jun 1 11:36:52 magnus-laptop wpa_supplicant[1100]: WPS-AP-AVAILABLE

Jun 1 11:37:52 magnus-laptop wpa_supplicant[1100]: last message repeated 9 times

Jun 1 11:37:52 magnus-laptop NetworkManager: <info> Activation (wlan0/wireless): association took too long.

Jun 1 11:37:52 magnus-laptop NetworkManager: <info> (wlan0): device state change: 5 -> 6 (reason Innocent

Jun 1 11:37:52 magnus-laptop NetworkManager: <info> Activation (wlan0/wireless): asking for new secrets

Jun 1 11:37:52 magnus-laptop NetworkManager: <info> (wlan0): supplicant connection state: scanning -> disconnected

Jun 1 11:37:57 magnus-laptop NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...

Jun 1 11:37:57 magnus-laptop NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...

Jun 1 11:37:57 magnus-laptop NetworkManager: <info> (wlan0): device state change: 6 -> 4 (reason Innocent

Jun 1 11:37:57 magnus-laptop NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...

Jun 1 11:37:57 magnus-laptop NetworkManager: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.

Jun 1 11:37:57 magnus-laptop NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...

Jun 1 11:37:57 magnus-laptop NetworkManager: <info> (wlan0): device state change: 4 -> 5 (reason Innocent

Jun 1 11:37:57 magnus-laptop NetworkManager: <info> Activation (wlan0/wireless): connection 'ComBort' has security, and secrets exist. No new secrets needed.

Jun 1 11:37:57 magnus-laptop NetworkManager: <info> Config: added 'ssid' value 'ComBort'

Jun 1 11:37:57 magnus-laptop NetworkManager: <info> Config: added 'scan_ssid' value '1'

Jun 1 11:37:57 magnus-laptop NetworkManager: <info> Config: added 'key_mgmt' value 'WPA-PSK'

Jun 1 11:37:57 magnus-laptop NetworkManager: <info> Config: added 'psk' value '<omitted>'

Jun 1 11:37:57 magnus-laptop NetworkManager: nm_setting_802_1x_get_pkcs11_engine_path: assertion `NM_IS_SETTING_802_1X (setting)' failed

Jun 1 11:37:57 magnus-laptop NetworkManager: nm_setting_802_1x_get_pkcs11_module_path: assertion `NM_IS_SETTING_802_1X (setting)' failed

Jun 1 11:37:57 magnus-laptop NetworkManager: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.

Jun 1 11:37:57 magnus-laptop NetworkManager: <info> Config: set interface ap_scan to 1

Jun 1 11:37:57 magnus-laptop NetworkManager: <info> (wlan0): supplicant connection state: disconnected -> scanning

Jun 1 11:37:58 magnus-laptop wpa_supplicant[1100]: WPS-AP-AVAILABLE

Jun 1 11:38:57 magnus-laptop wpa_supplicant[1100]: last message repeated 9 times

Jun 1 11:38:57 magnus-laptop NetworkManager: <info> Activation (wlan0/wireless): association took too long.

Jun 1 11:38:57 magnus-laptop NetworkManager: <info> (wlan0): device state change: 5 -> 6 (reason Innocent

Jun 1 11:38:57 magnus-laptop NetworkManager: <info> Activation (wlan0/wireless): asking for new secrets

Jun 1 11:38:57 magnus-laptop NetworkManager: <info> (wlan0): supplicant connection state: scanning -> disconnected

Jun 1 11:38:59 magnus-laptop NetworkManager: <info> (wlan0): device state change: 6 -> 9 (reason 7)

Jun 1 11:38:59 magnus-laptop NetworkManager: <info> Activation (wlan0) failed for access point (ComBort)

Jun 1 11:38:59 magnus-laptop NetworkManager: <info> Marking connection 'ComBort' invalid.

Jun 1 11:38:59 magnus-laptop NetworkManager: <info> Activation (wlan0) failed.

Jun 1 11:38:59 magnus-laptop NetworkManager: <info> (wlan0): device state change: 9 -> 3 (reason Innocent

Jun 1 11:38:59 magnus-laptop NetworkManager: <info> (wlan0): deactivating device (reason: Innocent.

Jun 1 11:38:59 magnus-laptop NetworkManager: <info> Policy set 'ComBort' (eth1) as default for routing and DNS.

Många tack!

1Newbe

FoHs bild

Tycker inte det ser ut som att den någonsin får en riktig anslutning till AP:n. Ser ut som den blir disconnect:ad i samma veva som den skickar lösenordet. Men det du kanske borde testa (tror inte du gjort det?) är om du kan ansluta till din AP utan något lösenord på den helt och hållet, bara för att se så att det går.

Personligen hade jag tagit bort dolt SSID, finns ingen anledning att ha det dolt egentligen eftersom det inte ger någon säkerhet, och det är en källa mindre för fel. Man kan ju inte riktigt veta var buggar i mjukvaran kan dyka upp. Och kanske ha på kanal 1, 6 eller 13 i första hand (Standardkanalerna).

1Newbes bild

Har försökt med synlig SSID, bytt till kanal 6/2 samt även ställt över AP:n till att sända först B/G/N sen bara N.

Inget hjälper. När jag klickar på näteverksikonen i Mint 9 syns mitt näteverk på det sämre inbyggda Broadcom BCM4312 802.11b/g men inte på N kortet D-Link DWA-140 som listas som Ralink 802.11n WLAN.

G kortet listar runt 18 nätverk men N kortet listar som mest 13 dock ej mitt.

Vet ej hur man ansluter utan lösenord till AP:n, den frågar hela tiden "Autentisering för trådlöst nätverk". När jag fyllt i rätt SSID, rätt lösenord (WPA & WPA2 personal frågas) försöker den ansluta men återkommer alltid tillbaks till den ifyllda rutan...

Kanske provar ominstalltilon av MInt med N stickan i nästa gång. Ibland sker mirakel utan att man förstår varför.

Många tack!

1Newbe

ibkas bild

Prova med Mint 8 Live.

Jag har en bärbar dator där Mint 8 fungerar men Mint 9 funkar inte, får hela tiden upp att man skallfylla i lösenord.

FoHs bild

Ja, det kanske kan vara värt att testa ett annat system. Personligen har jag en laptop med N-kort och N-router som jag kör Ubuntu 10.04 på, och den har jag inga sådana problem med. Så det är inget specifikt för N-standarden iaf.

1Newbes bild

Hej. Har provat att omisntallera Mint 9 men det sket sig. Samma fel på N kortet men nu vill den inte logga in det inbyggda trådlösa heller! Frågar efter inloggningsnyckelring nu men sen loopar frågan om inloggning...

Låter saken vila ett tag & återgår nog till Mint 8 som fungerade felfritt.

Lustigt vid denna installation var att den listade 2 proprietära drivrutiner för kortet, Broadcom B43 wireless driver & Drivrutin för trådlöst Broadcom STA. Har starkt minne av att den bara föreslog den 1:a vid förra installationen.

När väl STA drivrutinen installerats syns inte längre B43 i hårdvarudrivrutiner....

Nåväl. Får återgå till 8 & prova lyckan igen vid ett senare tillfälle.

Många tack!

1Newbe

FoHs bild

Jag tror att Broadcom STA är den drivaren som bygger på öppen källkod, men den måste dock hämta proprietärt firmware så det är därför den listas där. Om jag minns rätt brukar jag installera B43, som jag tror kommer från Broadcom själva. Hur som helst så kan det ibland vara problem med att installera Broadcom-drivarna via den där applikationen, men då kan man gå in i Synaptic i efterhand och installera dom. Sök på Broadcom i Synaptic så bör de dyka upp.

tufftuffs bild

b43 http://linuxwireless.org/en/users/Drivers/b43 är en öppen drivrutin, framtagen med reverse engineering. Tyvärr är inte -n stöd klart.

STA är en binärblob från Broadcom med ett tunt lager runt om för att koppla till olika kärnor. Enl Broadcom är den för BCM4311-, BCM4312-, BCM4313-, BCM4321-, och BCM4322-baserad hårdvara.

Jag provade Broadcoms drivrutin med Ubuntu 8.04. Jag fick ta bort en massa tecken ur WPA-nyckeln och essid, drivrutinen klarade inte alla tecken som den skulle. Fick dessuton köra med synligt essid. Men ingen här gillade Ubuntu, så jag har fortsatt med openSUSE.

1Newbes bild

Tackar. Fick igång det inbyggda långsammare kortet igen så nu slipper jag gå ner till Mint 8.

Avinstallerade först de trådlösa proprietära drivrutinerna och började om i pakethanteraren synaptic. Först B43 sen 4 till som listades när jag sökte på broadcom. För säkerhetsskull installerade jag alla i versionsordning.

Nöjd med Mint 9 x64 som startar snabbare än min tidigare Mint 8 installation och man vill ju helst prova de senaste.

Tillsvidare glömmer jag ursprungsfrågan om mitt externa USB N kort. Vill jag surfa för full får jag släpa fram lankabeln. Tids nog fungerar nog även D-Link DWA-140 i denna lättanvända dist.

Många tack!

1Newbe

Lyfangs bild

Jag ser att du är nöjd med Mint 9 x64, men om man har Linux Mint i386 kan man prova ndiswrapper.

Hittar du en Windows XP drivrutin för D-Link DWA-140 med en .inf fil, kan det kanske vara värt att prova med ndiswrapper. Tyvärr behöver man en 32 bitars dirvrutin för en 32 bitars kernel och en 64 bitars dirvrutin för en 64 bitars kernel.

I Mint 9 hittar man ndiswrapper i Menu, Administration, Windows-drivrutiner för trådlösa nätverkskort.

tufftuffs bild

Ehh, vad menar du? Finns inte ndiswrapper i Mint x64 eller finns inte 64-bit drivrutiner för XP till DWA-140? Jag har iallafall kört ndiswrapper och 64-bit XP-drivrutiner (för andra kort) på 64-bit openSUSE. Så i princip går det. Eller är det något konstigt med Mint?

Lyfangs bild

Hur många Windows XP Professional x64 drivrutiner finns det jämfört med Windows XP Home/Professional?

FoHs bild

Är inte tanken med ndiswrapper att bland annat inte behöva bry sig om arkitekturen? Ndiswrapper används väl för att köra 32-bits Flash-plugin på 64-bitars Linuxinstallationer. Borde det inte gå att installera en 32-bitars Windows-drivare i 64-bitars Linux Mint då?

fredentofts bild

Vad har NDIS (Network Driver Interface Specification) med flash att göra?

-
För övrigt anser jag att trådindenteringen måste lagas
-
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

FoHs bild

Inget! Jag tänkte på nspluginwrapper Smile

tufftuffs bild

Hur många Windows XP Professional x64 drivrutiner finns det jämfört med Windows XP Home/Professional?

Och vad har det med saken att göra? Är det inte bättre att du förklarar vad du menar med ditt inlägg istället för att ställa en fråga?

Här verkar det finnas en iallafall: ftp://ftp.dlink.de/dwa/dwa-140/driver_software/DWA-140_drv_RevAll_v1.70E...

1Newbes bild

 Hej. Tror jag ger upp. Fungerar snabbt med Mint 9 & G kortet. Tar lankabel vid hyrfilm & dylikt.

Mint har redan Ndiswrapper installerat i den lättanvända kontrollpanelen.

Har provat installera drivrutiner därifrån med olika fel. Allt från inget blink, konstant blink, fast sken från DWA-140 & låsning av allt utom muspekaren. Fick stänga av datorn med strömbrytaren då inget annat gick.

I DWA-140 revB v1.70EU som redan finns i min Win7 instalation d:\programfiles finns drivrutiner för Xp, Vista & W7. Har provat att installera W7x86 & W/x64 samt XPx64 samt XPx86Win2k dock utan gott resultat.

Tack för all hjälp ändå.

Många tack!

1Newbe

tufftuffs bild

Det finns ju generiska windows-drivrutiner att prova också: http://www.ralink.com.tw/support.php?s=1

Vista/Win7-drivrutiner (ndis6) stöds inte av ndiswrapper så det är ingen ide att prova, bara XP (ndis5 wdm).

För just 64-bitar kan det vara värt att kolla om du har senaste ndiswrapper, det har rättats några buggar i 64-bitsstödet ganska nyligen. Senaste utgåva är 1.56 från 2010-02-11. http://sourceforge.net/projects/ndiswrapper/files/

Ralink tillhandahåller linuxdrivrutiner också, jag vet inte hur bra dom är: http://www.ralink.com.tw/support.php?s=2

Lyfangs bild