Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

chmod

 För tusan, nu blir jag gramse!

Har inte mekat i en terminal på länge, och det märks. Skulle sätta upp en temporär filserver och skapa några enkla mappar åt några projektgrupper. Jag mekade dit grupperna och satte chmod g+s för att gruperna skulle äga alla nya filer.

Men .. varför skiter den i mina chmod kommadon. Alla nya filer som skapas i mapparna har förvisso rätt grupptillhörighet men de är fortfarande bara skrivbara för ägarna. 

Vad är det nu för magiskt kommando jag förglömt?

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

pettssons bild

Kolla vad du har för umask.

Den kan ställa till det. http://en.wikipedia.org/wiki/Umask

Annars så får diu kolla så du verkligen sätter sticky bit. Du kan köra hela kedjan med chmod 1xyz.
1:an i början anger sticky om jag inte minns fel.

In Coffea veritas - Sanningen finns i kaffet.

elwiss bild

jodå, i en ls får jag drwxrws---

Jag körde en chmod 770, jag vill inte andra ska kunna meka med filerna, men det räcker uppenbarligen inte med det. En umask ger mig 0022?

pettssons bild

Jag tror texten nedan säger det mesta (saxat från länken jag angav): A common umask value is 022 (masking out the write permission for the group and others), which ensures that new files are only writable for the owner (i.e. the user who created them). Another common value is 002, which leaves the write permission for the file's group enabled. This can be used for files in shared workspaces, where several users work with the same files.

Så om du sätter umask=002 så borde det fungera.

In Coffea veritas - Sanningen finns i kaffet.

elwiss bild

 Jo det låter fint, precis vad man är ute efter. Men hur sätter man det persistent för specifica directories? Allt jag lyckas googla upp hänvisar till user profile och annat, där kan jag väl näppeligen peka ut en umask för min fildelningsarea!?

Jisses vad man glömt..

elwiss bild

 Det där måste ju vara vad jag vill ha

 

STICKY DIRECTORIES 

       When the sticky bit is set on a directory, files in that directory may 
       be unlinked or renamed only by root or their owner. Without the sticky 
       bit, anyone able to write to the directory can delete or rename files. 
       The sticky bit is commonly found on directories, such as /tmp

 

Då borde ju en chmod -R 6770 myincrediblecoolfolder  fixa biffen, måste testa igen, glömde säkert något väsentligt