Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

Linux Mint Debian 32-bit 201012 och programlistor

Kör med Linux Mint Debian 32-bit 201012. Min  /etc/apt/sources.list:

deb http://packages.linuxmint.com/ debian main upstream import
deb http://ftp.debian.org/debian testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org testing main non-free
 
Hur ändrar man mellan stable, testing och unstable?

En programlista med rekommenderade program mm.:
Adobe Acrobat Reader Linux
Adobe Flash Player insticksprogram
Adobe Photoshop 7.0 windowsprogram
Audacity ljudredigeringsprogram
BankID säkerhetsprogram
build-essential installerar kompilatorer
Cinelerra videoredigeringsprogram
Conexant HSF Softmodem drivrutin
CrossOver Linux kommersiellt kompatibilitetslager för windowsprogram
DOSBox MS-DOS emulator
dos2unix konverterar en DOStextfil till UNIXformat
E-postklienten Thunderbird
Extreme Tux Racer spel
Festival text till tal
fglrx ATI drivrutin
FirstClass kommunikationssystem
GNU:s bildmanipuleringsprogram
Geany integrerad utvecklingsmiljö
Google Earth virtuell jordglob
HPLIP för utskrift, skanning och faxning
ImageMagick bildmanipulering
Kdenlive videoredigeringsprogram
Kino videoredigeringsprogram
KompoZer WYSIWYG HTML-redigeringsprogram
Linux kernel bigmem 4GB+ RAM
Mediaspelaren VLC
Microsoft Office windowsprogram
MingLiU teckensnitt
OpenArena förstapersonsskjutare spel
OpenOffice.org kontorsprogram
Pidgin Meddelandeklient
R:BASE windowsprogram
Skype IP-telefoni
Spotify windowsprogram
Sun Java för Java appletprogram
Svenska språkpaket
The Iceape Internet Suite (Seamonkey Internet Suite)
UNetbootin Live USB skapare
VirtualBox och Ubuntu 10.04 för BankID
Webbläsaren Firefox
Webbläsaren Google Chrome
Wine kompatibilitetslager för windowsprogram
 
Har ni några programförslag som t.ex. bokföringsprogram för Linux?

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

extons bild

Hur ändrar man mellan stable, testing och unstable?

Om du vill köra stable ska du installera Debian 6.0.

LMDE använder Debian Sids programkällor.

LINUX.EXTON.NET

Lyfangs bild

 LMDE är en rullande linuxdistribution, är Debian stable det?  

Debian Sid = unstable.

Kan man ändra sina LMDE källor från testing till stable?

Kan man ändra sina LMDE källor från testing till unstable? Görs på egen risk (som allt annat)!
 
Så här ser sources.list ut i LMDE:
##################################################
deb http://packages.linuxmint.com/ debian main upstream import backport
deb http://ftp.debian.org/debian testing main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org testing main non-free
##################################################
 
Så här ser sources.list ut i ExTiX KDE 101222:
################################################## 
# Unstable (Sid) 
deb ftp://ftp.uni-kl.de/debian-multimedia/ unstable main 
################################################## 
# Debian Sid: 
deb http://ftp.nl.debian.org/debian/ unstable main contrib non-free 
################################################## 
## KDE experimental 
deb http://qt-kde.debian.net/debian experimental-snapshots main 
deb-src http://qt-kde.debian.net/debian experimental-snapshots main 
##################################################
 
Den som känner för att experimentera lite kan byta ut sources.list (/etc/apt/sources.list) i LMDE mot "min" sources.list i ExTiX och sedan installera KDE 4.5.3 i LMDE. Skulle förvåna mig mycket om inte det fungerar alldeles utmärkt!
 
Källa: http://www.linuxportalen.se/articles/2010/12/25/julklappen-linux-mint-debian-edition#comment-92941

extons bild

Debian stable - f n Debian 6.0 - är (givetvis) en "rullande" dist i den meningen att du löpande kan uppdatera densamma. Även när Debian 7.0 släpps om några år.

LINUX.EXTON.NET

Lyfangs bild

'Den som känner för att experimentera lite kan byta ut sources.list (/etc/apt/sources.list) i LMDE mot "min" sources.list i ExTiX och sedan installera KDE 4.5.3 i LMDE. Skulle förvåna mig mycket om inte det fungerar alldeles utmärkt!'

Har du själv provat? Fungerar Linux Mints Uppdateringshanterare med Debian Unstables (Sids) förråd?

Lyfangs bild

 Kan man ändra sina LMDE källor från testing till unstable? Görs på egen risk (som allt annat)!

Ja

Linux Mint Debian "Sid" "instabil"
 
Görs på egen risk och jag tar inget ansvar för förlust eller skada som denna ändring kan orsaka
 
Öppna Terminalfönster och skriv:

gksudo gedit /etc/apt/sources.list

 
deb http://packages.linuxmint.com/ debian main upstream import
deb http://ftp.se.debian.org/debian sid main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org sid main non-free
 
Öppna Terminalfönster och skriv:

sudo apt-get update && sudo apt-get upgrade

Uppdatering av konfigurationsfiler tryck:
 
Enter (standardval)
 
Avinstallerade Firefox och installerade Iceweasel. Iceweasel 3.6.18 stängde utan anledning och ett program jag använde fungerade inte som det skulle.

extons bild

Kunde tro det! (D v s att det skulle gå bra på det hela taget).

Iceweasel kan du givetvis avinstallera. Installera förslagsvis Firefox 4.0 istället.

LINUX.EXTON.NET

Lyfangs bild

 Tänker vänta tills Firefox 4.0 finns i förråden för APT. Uppdaterade systemet 2011-04-08 och har Firefox 3.6.13 installerad.

extons bild

Ok, men just Firefox tycker jag man kan unna sig att ha i senaste version hela tiden (i ett "modernt" linuxsystem), eftersom Firefox inte är beroende av andra program/libs. D v s allt som (normalt) behövs för körning av Firefox är samlat i mappen firefox, som man förslagsvis kan placera i /usr/lib. Sen skapar man bara en länk från /usr/lib/firefox/firefox till /usr/bin/firefox. Klart!

Därmed behöver alltså inte Firefox finnas med i "förråden för APT".

LINUX.EXTON.NET

Lyfangs bild

 Med APT kan man uppdatera hela systemet. Debian/Ubuntu m.fl. med en terminalemulator:

sudo apt-get update && sudo apt-get upgrade

Med manuell installation behöver man uppdatera manuellt. Manuell installation kan medföra ouppdaterade program om man inte uppdaterar manuellt. Med pakethanterarna blir det enklare att hantera program.

extons bild

Ja, jag vet det, men just med Firefox kan du utan "men" göra så som jag beskriver i mitt förra inlägg.

LINUX.EXTON.NET

Lyfangs bild

 Iceweasel 3.6.18 stängde utan anledning och ett program jag använde fungerade inte som det skulle.

Rättning av version: Iceweasel 3.5.18

Lyfangs bild

Linux Mint Debian "Sid" "instabil" aptitude full-upgrade

Öppnade Terminalfönster och skrev:

sudo aptitude update
sudo aptitude full-upgrade

Uppdaterade resten med Uppdateringshanterare och systemet fungerar för mig.

Lyfangs bild

 Debian "Sid" "instabil" och säkerhetsuppdateringar?

Observera att säkerhetsuppdateringar för den ”instabila” utgåvan inte hanteras av säkerhetsgruppen.
 
Källa: Versionsfakta för Debian ”Sid”
 
Fungerar raden deb http://security.debian.org/ testing/updates main contrib non-free med Debian "Sid" "instabil"?

Lyfangs bild

 Om du vill köra stable ska du installera Debian 6.0.

Jag ska prova att byta sources.list från "testing" till "squeeze" (nuvarande stable).

Görs på egen risk som allt annat

Linux Mint Debian "Squeeze" "stabil"

gksudo gedit /etc/apt/sources.list

 
 
#############################################################
################### OFFICIAL DEBIAN REPOS ###################
#############################################################
 
###### Debian Main Repos
deb http://ftp.se.debian.org/debian/ squeeze main contrib non-free 
deb-src http://ftp.se.debian.org/debian/ squeeze main contrib non-free 
 
###### Debian Update Repos
deb http://security.debian.org/ squeeze/updates main contrib non-free 
deb http://ftp.se.debian.org/debian/ squeeze-proposed-updates main contrib non-free 
deb-src http://security.debian.org/ squeeze/updates main contrib non-free 
deb-src http://ftp.se.debian.org/debian/ squeeze-proposed-updates main contrib non-free 
 
 
Öppna Terminalfönster och skriv:

sudo aptitude update
sudo aptitude full-upgrade

extons bild

Det blir en så stor förändring/nergradering att det knappast är fråga om Linux Mint Debian längre.

LINUX.EXTON.NET

Lyfangs bild

 Linux Mint Debian (201012/201101) är baserad på Debian Squeeze testing. 

Debian 6.0.1 släpptes den 19 mars 2011.

Källa: http://www.debian.org/releases/stable/

Har problem med testings förändringar; nuvarande Linux Mint är baserad på Debian Wheezy testing och i pågående arbete.

Nedanstående har fungerat för mig FÖRE OMSTART men INTE EFTER, jag säger att det görs på egen risk som allt annat

1. Öppnade Terminalfönster och skrev:

sudo apt-get update && sudo apt-get dist-upgrade 

2. Öppnade Synaptic > Redigera > Rätta till trasiga paket

3. Synaptic > Markera alla uppgraderingar

4. Högerklickade på mintUpdate Uppdateringshanterare och Avsluta

5. Öppnade Terminalfönster och skrev:

mintupdate &

6. mintUpdate 4.2.9 Uppdateringshanterare > Uppdatera

Ditt system är uppdaterat

7. Upprepa INTE från steg 1 I DAGSLÄGET om mintUpdate klagar på trasiga paket

EDIT: Hämtade packeten 2011-04-13 och efter installation och omstart fick jag GRUB > svart skärm. (recovery mode) fungerar efter jag valt det i GRUB men inte något annat val.

Källa: [LÖST på sätt och vis... ] Uppdatering förstör LMDE, igen...

Lyfangs bild

 I dagsläget rekommenderar jag Linux Mint Debian "Squeeze" "stabil" om man vill köra med LMDE. LMDE testing och LMDE sid verkar ha kritiska fel i dagsläget.

LMDE testing:

[LÖST på sätt och vis... ] Uppdatering förstör LMDE, igen...

LMDE sid:

[LÖST] Linux Mint Debian "Sid" "instabil" uppdateringsproblem

Lyfangs bild

 Jag installerade KDE med kde-full från Synaptic. Jag söker efter language-support-writing-se, language-support-se, language-pack-se, language-pack-kde-se, language-pack-se-base och language-pack-kde-se-base i Synaptic.

Jag hittar inte Starta om eller Stäng av i Kickoff menyn Linux Mint Debian 32-bit 201012 och KDE. Tidigare har Kubuntu 9.10 strulat:
 
Kubuntu 9.10 starta om och stänga av i Kickoff menyn fungerar inte

Lyfangs bild

 I Linux Mint Debian 32-bit 201012 installerades KDE 4.4.5 från förråden. Jag hittade inte de samiska språkpaketen kde-l10n-se eller kde-i18n-se i förråden.

Lyfangs bild

Lägga till nya packet som eventuellt kan tas med i Debian i framtiden.
 
Till: submit@bugs.debian.org
Ämne: RFP: kde-l10n-se -- Northern Sami (se) localization files for KDE
 
Package: wnpp
Version: 4:4.4.5-1; reported 2011-03-21
Severity: wishlist
 
* Package name : kde-l10n-se
Version : 4:4.4.5-1
Upstream Author : Børre Gaup <boerre@skolelinux.no>
* URL : http://developer.skolelinux.no/info/samisk/index.html.en
* License : GPL
Description : Northern Sami Localization for KDE. This package contains the Northern Sami translations for applications from the official KDE 4 release.
 
Till: submit@bugs.debian.org
Ämne: Subject: RFP: koffice-l10n-se -- Northern Sami (se) language support for Koffice
 
Package: wnpp
Version: 2.3.1-3; reported 2011-03-21
Severity: wishlist
 
* Package name : koffice-l10n-se
Version : 2.3.1-3
Upstream Author : Børre Gaup <boerre@skolelinux.no>
* URL : http://developer.skolelinux.no/info/samisk/index.html.en
* License : GPL
Description : Northern Sami Localization for KDE. This package contains the Northern Sami translations for all applications in the KDE Office Suite.
 
Till: submit@bugs.debian.org
Ämne: RFP: ipmasq -- IP Masquerade NAT (Network Adress Translation)
 
Package: wnpp
Version: 4.0.8-7; reported 2011-03-21
Severity: wishlist
 
* Package name : ipmasq
Version : 4.0.8-7
Upstream Author : Brian Bassett <bbassett@bbassett.net>
* URL : http://www.bbassett.net/ipmasq/
* License : GPL
Description : This package contains scripts to initialize IP Masquerade for use as a firewall. IP Masquerade is a feature of Linux that allows an entire network of computers to be connected to another network (usually the Internet) with only one network address on the other network. IP Masquerade is often referred to as NAT (Network Address Translation) on other platforms.
 
Hämtningssida för ipmasq_4.0.8-7_all.deb
 
Om du kör Debian rekommenderas det å det bestämdaste att du använder en pakethanterare som aptitude eller synaptic för att hämta och installera paket, istället för att göra det manuellt via webbplatsen.
 
Du bör kunna använda valfri av de angivna speglarna genom att lägga till en rad i din /etc/apt/sources.list på den här formen:
 
deb http://ftp.de.debian.org/debian lenny main 
Ersätt ftp.de.debian.org/debian med spegeln i fråga.
 
Källa: http://packages.debian.org/lenny/all/ipmasq/download
 
Fungerar packet från Debian Lenny med Linux Mint Debian 32-bit 201012?
 
/ Lyfang, Aslak Inga 2011

Lyfangs bild

 Till: submit@bugs.debian.org
Ämne: Subject: RFP: usb-imagewriter -- A GUI tool to write .img files
 
Package: wnpp
Version: 0.1.3-0ubuntu4; reported 2009-10-27
Severity: wishlist
 
* Package name : usb-imagewriter
Version : 
Upstream Author : Oliver Grawert
* URL : https://launchpad.net/usb-imagewriter
* License : GPL
Description : A GUI tool to write .img files like produced by the ubuntu-mobile team for UME to USB Keys

Lyfangs bild

 Till: submit@bugs.debian.org

Ämne: RFP: fribid -- FriBID is an open source software for the Swedish e-id system called BankID. 
 
Package: wnpp
Version: 0.2.2; reported 2011-04-10
Severity: wishlist
 
* Package name : fribid
Version : 0.2.2
Upstream Author : Samuel Lidén Borell <samuel@slbdata.se>
* URL : http://fribid.se/
* License : MIT
Description : FriBID is an open source software for the Swedish e-id system called BankID. It's an open source software to handle BankID on websites.

Lyfangs bild

 VirtualBox och Ubuntu 10.04 för BankID

[LÖST] Oracle VM VirtualBox problem

Lyfangs bild

 Linux Mint Debian "Experimental"

Görs på egen risk och jag tar inget ansvar för förlust eller skada som denna ändring kan orsaka

deb http://packages.linuxmint.com/ debian main upstream import
deb http://ftp.se.debian.org/debian sid main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org sid main non-free
deb http://ftp.se.debian.org/debian experimental main

Kunde inte verkställa ändringar!
Lös problemet med de trasiga paketen först.

Källa: Uppdateringshanterare

Lyfangs bild

 apt-get install -t experimental iceweasel

Källa: http://mozilla.debian.net/

sudo apt-get install -t experimental iceweasel

Läser paketlistor... Färdig
Bygger beroendeträd         
Läser tillståndsinformation... Färdig
Några paket kunde inte installeras. Det kan betyda att du har begärt
en omöjlig situation eller, om du använder den instabila utgåvan
att några nödvändiga paket ännu inte har skapats eller flyttats
ut från "Incoming".
Följande information kan vara till hjälp för att lösa situationen:

Följande paket har beroenden som inte kan tillfredsställas:
 iceweasel : Beroende av: xulrunner-2.0 (>= 2.Innocent men det kommer inte att installeras
E: Trasiga paket

extons bild

"Experimental" är väl ändå att ta i. Ska du köra det bör du har ett litet system och järnkoll på varje ingående paket.

xulrunner: Kolla om kommandot

sudo apt-get install -t experimental xulrunner

ger dig efterfrågad version.

LINUX.EXTON.NET

Lyfangs bild

 Sid har Iceweasel 3.5.18-1 och Experimental har Iceweasel 4.0-3.

Lyfangs bild

deb http://packages.linuxmint.com/ debian main upstream import
deb http://ftp.se.debian.org/debian sid main contrib non-free
deb http://security.debian.org/ testing/updates main contrib non-free
deb http://www.debian-multimedia.org sid main non-free
deb http://ftp.se.debian.org/debian experimental main

sudo apt-get update
sudo apt-get install -t experimental xulrunner

Läser paketlistor... Färdig
Bygger beroendeträd         
Läser tillståndsinformation... Färdig
Paketet xulrunner är inte tillgängligt, men ett annat paket hänvisar till det.
Det kan betyda att paketet saknas, har blivit föråldrat eller endast
är tillgängligt från andra källor

E: Paketet "xulrunner" har ingen installationskandidat