Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

[LÖST] Kan inte uppdatera LMDE

Jag har just installerat LMDE på en maskin och ska till att uppdatera 725 paket. När jag kör uppdateringshanteraren får jag felmeddelandet "Kunde inte verkställa ändringar!, Lös problemet med de trasiga paketen först."

Vadå, "Lös problem med trasiga paket??" Väldigt hjälpsamt Sad.

Har provat
apt-get update
apt-get autoclean
apt-get clean
apt-get autoremove
apt-get upgrade
apt-get update --fix-missing

Det laddas ner för fullt och händer en massa men när jag sedan kollar uppdateraren står det fortfarande att jag behöver uppdatera 725 paket - men det går inte p g a de TRASIGA PAKETEN!! :'( Moment 22?

Vad gör jag fel? Har installerat LMDE på flera maskiner tidigare utan detta problem.

 

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

Lyfangs bild

Prova öppna Terminalfönster och skriv:

sudo apt-get update && sudo apt-get upgrade

Starta om datorn och starta sedan Uppdateringshanterare (mintUpdate 4.2.6).

mint debian

tux-svens bild

OK, det var ju ett bra tips. :)   Jag gjorde det på ett betydligt krångligare  sätt som beskivs i en annan tråd här...

Du svarade nej på alla frågor om uppdatering av konfigurationsfiler antar jag?

---

Windows are for houses, Linux is for computers!

 

frilas bild

Vad betyder detta? Ska jag göra något?

 

pam (1.1.2-1) unstable; urgency=low

  * Name of option for minimum Unix password length has changed

    The Debian-specific 'min=n' option to pam_unix for specifying minimum
    lengths for new passwords has been replaced by a new upstream option
    called 'minlen=n'.  If you are using 'min=n' in
    /etc/pam.d/common-password, this will be migrated to the new option name
    for you on upgrade.  If you have configured pam_unix password changing
    elsewhere on your system, such as in a PAM profile under
    /usr/share/pam-configs or in other files in /etc/pam.d, you will need to
    update them by hand for this change.

 -- Steve Langasek <vorlon@debian.org>  Tue, 31 Aug 2010 23:09:30 -0700

patch (2.6.1-1) unstable; urgency=low

  The options -U --unified-reject-files and --global-reject-file have now been
  removed.

 -- Christoph Berg <myon@debian.org>  Sun, 06 Feb 2011 20:17:11 +0100

usb-modeswitch-data (20110227-1) unstable; urgency=low

  usb-modeswitch from its 1.1.7 version searches for its hardware switching
  database in a tarball (/usr/share/usb_modeswitch/configPack.tar.gz) first.
  Hence usb-modeswitch-data now only ships this tarball instead of the raw
  database files under /etc/usb_modeswitch.d .

  If you had modified some of these database files, they have been kept in
  place and will override the entries from the tarball, see the README.Debian:
 

Lyfangs bild

Du svarade nej på alla frågor om uppdatering av konfigurationsfiler antar jag?

Enter (standardval)

frilas bild

Vad f-n är det som är trasigt?? Sad

frilas bild

Gjorde precis som du beskriver. Uppdaterde därefter till mintUpdate 4.2.6 men jag får exakt samma fel. Trasiga paket...??? Puzzled

tux-svens bild

Nya mintupdate 4.2.6 uppgraderar inte konfigurationsfilerna utan bara prorampaketen, vilket gör allt enklare i fortsättningen  Smile

Det finns en tråd i ämnet med clem som deltagare på linuxmint forum här:  http://forum.linuxmint.com/viewtopic.php?f=141&t=67502&start=120

---

Windows are for houses, Linux is for computers!

 

tux-svens bild

Det funkar.  Den första delen av kommandot uppdaterar till de nya test-repositoryna (eftersom de gamla blivit Squeeze)

sudo apt-get update

Den andra delen av kommandot gör hela uppdateringen. 

sudo apt-get dist-upgrade

Vid fråga om uppgradering av config-filer skall du behålla de gamla!! (default-värde)

Dessutom är det viktigt att scriptet får gå färdigt tills prompten kommer tillbaka.   För mig stannade scriptet emelletid så jag var tvungen att trycka "Q" för att ta bort den stoppande inotexten så att scriptet kunde fortsätta.   (Det håller på en god stund)

Efter omstart var allt ljuvligt - bara fågelkvitter och solsken! Laughing out loud

---

Windows are for houses, Linux is for computers!

 

frilas bild

Ja, nu till slut gick det! (att uppgradera, alltså...).
Det var Q:et det hängde på. Jag tryckte ctrl-c innan uppgraderingen var klar.