Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

DNS-hjälp!!!

Sedan jag uppgraderat till Squeeze har jag fått starta om systemet någon gång, precis som Windows gör hela dagarna. Vid reboot tappar jag bort mina DNS:er. I /etc/resolv.conf får jag inte skriva något eftersom systemet sköter den biten.

Det måste finnas någonstans att skriva in dem permanent!!

Jag är ingen guru på linux, bara en user, lär mig bara vad som behövs för stunden. Nu behövs en kunnig person som vet vad han gör. Smile

 

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

danjeels bild

 Jag har aldrig provat själv men jag gissar att du kan plocka bort

"option domain_name_servers" från /etc/dhcpcd.conf

FoHs bild

I NetworkManager kanske? Finns val för att skriva in DNS:er där om man redigerar anslutningarna (och väljer DHCP adresses only).

Själv har jag mina egna DNS:er i routerns inställningar.

LAltinells bild

Skrivskydda filen med "sudo chattr +i /etc/resolv.conf"

Tillåt skrivning till filen med "sudo chattr -i /etc/resolv.conf"

Jag skriver min resolv.conf -fil själv. Dessa kommandon hindrar NetworkManager att skriva över filen! Smile