Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

Nexus Personal BankID, OpenSUSE-64 12.1 & Firefox 8

Hej,

Vill bara visa hur jag får igång BankID på en nyinstallerad OpenSUSE 64-bitars med Firefox 8. Hoppas det kan hjälpa någon annan också.

 /Jocke

Tanka hem senaste Nexus programvara från: https://install.bankid.com/

Packa upp filen "BISP-4.18.1.10899.tar.gz"

Kör installationen (som root):
  ./install.4.18.1.10899.sh i

Se till att ha nsplugin.so installerad:

  nspluginwrapper -i ./usr/local/lib/personal/libplugins.so

Kontrollera att nsplugin finns där:

  nspluginwrapper -l                                                                                  

  /usr/lib64/browser-plugins/npwrapper.libplugins.so
    Original plugin: ./libplugins.so
    Plugin viewer: /usr/lib/nspluginwrapper/i386/linux/npviewer
    Wrapper version string: 1.4.4-1

Installera libpng12.so.0:    (32-bitars, 64 finns redan)
  zypper in libpng12-0-32bit    (libpng14 kommer med i OpenSUSE 12.1, måste vara libpng12)

Installera libgcrypt11-32bit    (32-bitars, 64 finns redan)
  zypper in libgcrypt11-32bit

Installera libidn-32bit        (32-bitars, 64 finns redan)
  zypper in libidn-32bit

För att köra från kommandorad (och se felmeddelanden): "personal" vid prompten.

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

fredentofts bild

Gött med info, har du testat BankID på fil eller på kort?

-
För övrigt anser jag att trådindenteringen måste lagas
-
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

jbrostens bild

Hejsan,

Jag kör med BankID på fil.

  /Jocke

Edisons bild

Det går inte längre att ladda ner Nexus från https://install.bankid.com/ om man har 64-bitsystem. Trollen på Finansiell ID-Teknik BID AB förnekar sig inte.

Någon vänlig själ som har möjlighet att förse mig med en länk till 32-bitvarianten?

tux-svens bild

Jag hämtade min här: http: https://install.bankid.com/Repository/BISP-4.19.0.11351.tar.gz

OBS!  Bank-id är uppgraderad till ny version.  Jag har inte installerat den själv ännu.

/Sven

---

Windows are for houses, Linux is for computers!

 

Edisons bild

 

Ok, tack. Hittade nyss den här generiska länken som också funkade:

https://install.bankid.com/Download?defaultFileId=Linux

Jag gör ett försök att lägga på senaste BankID och återkommer med resultatet.

 

Det funkar utmärkt att lägga in BankID på 64-bitarssystem, så jag fattar inte varför de försöker blockera nedladdning. Behövde dock ändra lite från guiden ovan:

 

* Ändra i install.4.19.0.11351.sh så sökvägen blir korrekt till browser-plugins för libplugins.so vid installation/avinstallation av Nexus. Det innebär i mitt fall att efter raden

rm -f /usr/local/bin/persadm

lägga till  

rm -f /usr/lib/browser-plugins/libplugins.so

för korrekt avinstallation, och ersätta raden efter

#Install plugin for FF3

med   

ln -s $INSTALL_DIR/personal/libplugins.so /usr/lib/browser-plugins

, spara och därefter köra installationen enl. guiden.

 

* Sökvägen för nspluginwrapper måste även ändras jämfört med guiden till

nspluginwrapper -i ./usr/lib/browser-plugins/libplugins.so

för att Nexus ska starta när BankID efterfrågas.

 

* Importera BankID funkar enbart direkt från USB-sticka, det går inte att kopiera över BankID-filen till HDn och importera. Det går heller inte att döpa om filen till nåt annat, utan det är cut and paste för hela det långa filnamnet som gäller (om man inte vill handknacka in det i persadm, förståss)...

 

Hoppas att detta är till hjälp för någon

/Edison

tufftuffs bild

Hmm, med "User Agent Switcher" ställd till 32-bitars ubuntu så får jag inga klagomål. Men inte heller någon länk till nedladdningen. Testen av BankID funkar bra oberoende av user agent. Men jag får informationen att min version är giltig men bör uppgraderas. Och hänvisas åter till install.bankid.com det det inte finns någon nedladdningslänk! Inte ens om jag påstår at jag kör WindowsXP får jag någon nedladdningslänk. Urk, som du sa, trollen på Finansiell ID-Teknik BID AB förnekar sig inte.

För övrigt så installerade jag senaste versionen på dotterns dator och den verkar funka. Kör med SHBs kortläsare med USB-sladd och openSUSE.

 

gorades bild

Fick just en länk till en version, som verkar klara x64 direkt utan ndiswrapper, åtminstone på MintLMDE x64. och Firefox 11.0  Kolla på: install.bankid.com/Repository/BISP-4.19.0.11351.tar.gz

morganols bild

Superbra, tack Jocke! Smile

Funkar finfint på Mageia 2 - 64bit, KDE.

Nexus erbjuder numera nedladdning enklare på https://install.bankid.com/Download/All

Jag följde din suveräna instruktion i princip helt och hållet, med liten avvikelse i vilka paket jag behövde installera, alla från mageias repo:

64 bit: ndiswrapper

32 bit: libpng12_0, libcanberra-gtk0, liboxygen-gtk
(jag hade redan libgcrypt11, libidn11)

      Tilläggas kan att

§ Firefox måste startas om

§ test.bankid.com vägrar utföra test med 64 bit linux

§ Har du bankID lagrat på annan dator är det enklast att helt enkelt kopiera över dolda mappen ~/.personal

________

Kör Linux i jobbet och hemma. Frun och barnen med. Enklast så.

morganols bild

Men för %##!!@

Denna vecka har Bankid spärrat för 64-bit linux, även ändra bowser user agent string hjälper inte.

Så nu har jag bara för Nexus motvalsfasoner tvingats installera Virtualbox och i den installera mageia 2 32-bit, och BankID ett varv till enligt http://mageiasv.blogspot.se/2012/10/bank-id-och-handelsbankens-kortlasar...
 

 

________

Kör Linux i jobbet och hemma. Frun och barnen med. Enklast så.

morganols bild

Njaha, upptäckte att ett alternativ är att avinstallera Firefox 64-bit version,  avinstallera ndiswrapper (tar även bort länkarna), installera 32-bit Firefox versionen, och följa 32-bit BankID instruktionen:

# cd /usr/lib/mozilla/plugins/
# ln -s /usr/local/lib/personal/libplugins.so
 

Firefox user agent är i original nu enligt http://whatsmyuseragent.com/ :
Mozilla/5.0 (X11; Linux i686 on x86_64; rv:10.0.11) Gecko/20100101 Firefox/10.0.11
Tog bort " i686 on x86_64" medelst tillägget "User Agent Changer" så det blev:
Mozilla/5.0 (X11; Linux; rv:10.0.11) Gecko/20100101 Firefox/10.0.11

Funkar logga in på Banken, skaffa nytt BankID, samt alla tester på test.bankid.com
 

Jusst  nu iallafall...

OBS nu funkar ju inte (64-bit) flashpluginnen. Antagligen kan man avinstallera 64-bit och installera 32-bit versionen, men tills vidare fortsätter jag att köra allt utom BankID i Opera, som jag gillar.

________

Kör Linux i jobbet och hemma. Frun och barnen med. Enklast så.

morganols bild

...Men frun älskar Firefox... Efter nytt lyckat försök sammanställer jag här komplett instruktion:

____Nexus BankID fullt OK idag på Mageia 2 64 bit med Firefox 10.0.11 (ESR), 64 bit__
Kortfattad instruktion
§ Installera 64 bit: ndiswrapper, drar med ndiswrapper-i386
§ Installera 32 bit: libpng12_0, libcanberra-gtk0, liboxygen-gtk, och jag hade redan libgcrypt11, libidn11
§ Hämta Nexus installationsfil från https://install.bankid.com/Download/All, packa up den och gå in,
passa på att sno personal.desktop till skrivbordet, öppna terminal i mappen, bli root och
# ./install.4.19.1.11663.sh i
# nspluginwrapper -i /usr/local/lib/personal/libplugins.so
# nspluginwrapper -l #ska lista resultatet.
§ Som vanlig användare kör från terminal /usr/local/bin/personal så ser du eventuell felutmatning.
§ Har du BankID på linux tidigare så kopiera in ~/.personal från din tidigare installation, annars exportera/importera enligt Nexus handledning som finns som html i mappen du packade upp
§ I firefox ändrade jag user-agent identifieringen (t.ex med tillägget User Agent Changer) och tog bort CPU info (x86_64) så det blev: "Mozilla/5.0 (X11; Linux; rv:10.0.11) Gecko/20100101 Firefox/10.0.11" (utan denna ändring kom jag in överallt utom på test.bankid.com och kunde heller inte få nytt BankID) 

________

Kör Linux i jobbet och hemma. Frun och barnen med. Enklast så.

FoHs bild

Har du testat Fribid? Kör det själv, har Swedbank, och det fungerar väldigt bra för de tjänster där jag behöver det (CSN, Försäkringskassan etc).

http://fribid.se/

Finns ett paket för Mageia här: https://bugs.mageia.org/show_bug.cgi?id=983#c11 (se under attachments längst ner).