Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

Beroende av nvidia-glx ?!

Hej kära Linux Portalare!

Nu känner jag att det är dags att uppdatera world profilen i mitt Gentoo system.
Men den klagar över ett beroende, nvidia-glx(?) som nu inte går att lösa efter som det inte finns någon sådan ebuild.
Jag installerade nvidia-drivers för ett bra tag sedan..
Hur gör man när det blir sådana här typer av problem?

Jag raderade /usr/portage och syncade-om och försökte installera om de paket med detta beroende, misslyckat resultat.
Körde emerge --regen world, misslyckat resultat (klagar på beroende).
Körde sist men inte minst emerge --nodeps world, misslyckat resultat.

Såhär står det när den klagar:
########################################################################
localhost ~ # emerge -uDNpv world

These are the packages that would be merged, in order:

Calculating world dependencies /
emerge: there are no ebuilds to satisfy "media-video/nvidia-glx".
(dependency required by "media-libs/libsdl-1.2.11" [ebuild])

!!! Problem resolving dependencies for www-client/mozilla-firefox-bin
!!! Depgraph creation failed.
########################################################################

Hur kan man avhjälpa detta utan att installera om hela systemet? ***help***

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

magnusbergs bild

Det är lätt.

Använd Google och sök på:
Calculating world dependencies /Calculating world dependencies /
emerge: there are no ebuilds to satisfy "media-video/nvidia-glx".
(dependency required by "media-libs/libsdl-1.2.11" [ebuild])

Och svaret blir:
emerge -C nvidia-glx nvidia-kernel
emerge nvidia-drivers
revdep-rebuild
/etc/init.d/xdm stop
rmmod nvidia
modprobe nvidia
/etc/init.d/xdm start

zidzs bild

Guld guld guld!
Klant som jag var så hade jag inte avinstallerat nvidia-kernel och -glx på just den datorn :-S
Detta hjälpte mig, stort tack!