Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

problem med kernel-source-restriced?

de nya nvidia drivrutinerna har landat! Smile

http://www.nvidia.com/object/linux_display_ia32_1.0-9746.html

men jag får ett felmeddelande när jag försöker installera:

No precompiled kernel interface was found to match your kernel; would you like the installera to attempt to download a kernel interface for your kernel from the NVIDIA ftp site (ftp://download.nvidia.com)?

klickar på "YES"

sen kommer ett till meddelande:

No matching precompiled kernel interface was found on the NVIDIA ftp site; this mean that the installer will need to compile a kernel interface for your kernel.

sen klickar jag på "OK"

sen kommer ett till:

Unable to find the kernel source tree for the currently running kernel. Please make sure you have installed the kernel source files for your kernel and that they are properly configured; on Red Hat linux system for example be sure that you have the 'kernel-source' or 'kernel-devel' RPM installed, you may have specify the kernel source path with the '--kernel-source-path' command line option.

sen kommer ännu ett till

installation has failed please see the log files bla bla bla....

och där står de samma sak som jag har skrivet i meddelandena här.

jag vet faktiskt inte vad jag ska göra :S

skulle vara tacksam för hjälp Smile

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

johan_pirates bild

jag kollade min kernel version med: uname -r
och fick: 2.6.17-10-386

jag hade bara 2.6.17-10

så jag installerade de, och sedan nvidia drivrutinerna.

rebootade.

och sen x-fel :S

"Error: API mismatch: the NVIDIA kernel module has the version 1.0-7184, but this X module has the version 1.0-9746. Please make sure that the kernel module and all NVIDIA driver components have the same version.

-------

Kristians bild

Sök efter ett paket som innehåller orden 2.6.17-10-386 och headers. Kör dessvärre Pyttemjuk hemma hos far i jul och dessutom surfar jag via modem så jag kan inte kolla exakt vad paketet heter Sad)

apt-cache search 2.6.17-10 | grep headers

sudo apt-get install blablabla

----------------------------------
where my .emacs is, that's my home

---------------------------------------

 

alberts bild

Det blir alltid problem när man blandar filer som hanteras av APT och filer man bygger själv. Som t ex nvidias drivrutiner. Om du verkligen vill bygga en egen version av nvidias drivrutin, ladda hem källkodspaketet för den senaste versionen som finns som source deb (titta under katalogen pool på någon Ubuntu-mirror). Packa sedan upp .org-filen och applya patchen (patch -p0 < namnet_på_patchfilen) och gå sedan in i katalogen och bygg paketet:
 

$ dpkg-buildpackage -us -uc

 
Om det funkar ska det skapas en .deb fil som du kan installera med dpkg -i.

Titta t.ex. under:

http://se.archive.ubuntu.com/ubuntu/pool/restricted/

Det är precis så man gör när man backportar ett paket från en nyare dist till en äldre.

Men du kommer antagligen få problem ändå nästa gång linuxkärnan uppdateras hos Ubuntu. Därför är det betydligt enklare att använda den versionen som finns med bland standardpaketen. Avinstallera alla restricted och installera om dem igen.

johan_pirates bild

har redan dessa paketen installerade.

jag tror ju då att jag behöver en nyare version av nvidia-kernel-common, isåfall vad får jag tag i de? :S

-------

johan_pirates bild

fick hjälp Laughing out loud

men tack ändå Smile

-----

Kristians bild

X går inte igång?

Man ska aldrig blanda nvidias drivrutiner ifrån hemsidan med de som finns i apt-n, då händer precis det som hänt dig Sad

Lös problemet genom att boota i felsäkert läge (då blir du root och X går inte igång). Härifrån tar du bort nvidia-kernel-common. Oroa dig inte om något annat slinker med, jag gjorde så själv för en vecka sedan.

När det är gjort kan du för säkerhets skulle ominstallera nvidias drivrutiner med den fil du laddat hem. Sen ska det funka som vanligt (du får dock en ny och lite fräckare nvidia-logo Smile)

----------------------------------
where my .emacs is, that's my home

---------------------------------------