Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

Ljudproblem

Hej
Nu har jag ljudproblem på min dator. Jag försökte installera ett SB Audigy ljudkort men misslyckas.

jag gör enligt instruktionerna på http://alsa-project.org/ och allt verkar fungera, men när jag ska köra alsamixer får jag ett felmedlenade

alsamixer: function snd_ctl_open failed for default: No such device

jag pröver istället med att skriva amixer men får då det här medelandet
amixer: Mixer attach default error: No such device

under uppstarten verkar något bli fel, när jag kör dmesg finns det här medelandet med

ALSA /usr/src/alsa/alsa-driver-1.0.13/acore/timer.c:1985: unable to register timer device (-22)
ACPI: PCI Interrupt 0000:02:08.0[A] -> GSI 19 (level, low) -> IRQ 169
ALSA /usr/src/alsa/alsa-driver-1.0.13/acore/rawmidi.c:1549: unable to register rawmidi device 0:1
EMU10K1_Audigy: probe of 0000:02:08.0 failed with error -22

Någon som vet vad som är fel, jag har googlat men inte hittat någon lösning, eller åtminstånde inte hittat en lösning som jag förstår.

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

curiums bild

Jag hittade två länkar, har alltså ingen aning om dem kan hjälpa dig men kolla på dem iaf för det kan gå:
http://www.mail-archive.com/alsa-user@lists.sourceforge.net/msg13874.html
http://www.linuxquestions.org/questions/showthread.php?t=157454
--

--

abergmans bild

jag har haft samma problem, har du provat köra alsaconf ?
Jag tror inte jag löste det, utan installerade om hela Alsa och började om.

--------------


 

 

skleps bild

Bestämde mig för att göra som du och ominstallera Alsa. Nu kan jag starta alsamixer men får fortfarande inget ljud. När jag går igenom alsas Trouble Shooting är det några saker som inte verkar stämma.

Såhär står det
"Make sure that /proc/asound/cards lists your card, as card number zero."

och när jag skriver /proc/asound/cards kommer det här upp i terminalen

/proc/asound/cards: line 1: 0: command not found
/proc/asound/cards: line 2: syntax error near unexpected token `('
/proc/asound/cards: line 2: ` Audigy 1 [Unknown] (rev.5, serial:0x20051102) at 0xef00, irq 169'

Och nu när jag kör gmesg hittar jag ett nytt felmedelande
ALSA sound/pci/ac97/ac97_codec.c:1923: AC'97 1 does not respond - RESET
ALSA sound/pci/ac97/ac97_codec.c:1932: AC'97 1 access is not valid [0xffffffff], removing mixer.
ALSA sound/pci/intel8x0.c:2138: Unable to initialize codec #1
intel8x0_measure_ac97_clock: measured 55933 usecs
intel8x0: clocking to 48000
ali1535_smbus 0000:00:03.1: ALI1535_smb region uninitialized - upgrade BIOS?
ali1535_smbus 0000:00:03.1: ALI1535 not detected, module not inserted.
ali1563: SMBus control = 5003
ali1563_probe: Returning 0
GSI 18 sharing vector 0xB9 and IRQ 18
ACPI: PCI Interrupt 0000:00:0f.0[A] -> GSI 20 (level, low)

Det står något om upgrade BIOS, men hur gör jag det?

skleps bild

Hade redan googlat fram de sidorna men klarade fixade det ändå inte
Tack ändå, hjälpen uppskattas!

skleps bild

Dubbelpost

fredentofts bild

Testa att istället skriva:

less /proc/asound/cards

Eftersom det är en textfil och inget program.

-----
Argumentera aldrig med idioter.
De drar bara ner dig till sin nivå och vinner på erfarenhet!

-
För övrigt anser jag att trådindenteringen måste lagas
-
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

skleps bild

När man läser på aslas hemmsida står det någonting om att "As a wild guess, for most recent low cost AC97 based motherboards and laptops, try the snd-intel8x0 driver." Hur gör jag om jag vill köra den drivrutin som de föreslår?

skleps bild

less /proc/asound/cards ger följande resultat... tror ni att det är här jag ska leta fel eller verkar det vara ok?

0 [Audigy ]: Audigy - Audigy 1 [Unknown]
Audigy 1 [Unknown] (rev.5, serial:0x20051102) at 0xef00, irq 169