Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

Problem att köra Tibia

jag har gjort en mapp "/usr/local/games/tibia" där jag lägger alla windows tibia filer i. Sedan kör jag med "wine Tibia.exe" i terminalen. Ett tomt fönster som heter Tibia kommer upp men det är "genomskinligt". I terminalen står detta:
--------------------------------------------------

fixme:ddraw:IDirectDrawImpl_SetCooperativeLevel (0x16d718)->((nil),00000008)
fixme:d3d:IWineD3DStateBlockImpl_Release Releasing primary stateblock
root@perra-laptop:/usr/local/games/tibia# wine Tibia.exe
libGL warning: 3D driver claims to not support visual 0x5b
fixme:d3d:IWineD3DDeviceImpl_GetAvailableTextureMem (0x16de28) : stub, simulating 64MB for now, returning 64MB left
fixme:d3d:IWineD3DStateBlockImpl_Release Releasing primary stateblock
fixme:ddraw:IDirectDrawImpl_SetCooperativeLevel (0x16e0c0)->(0x20028,00000008)
err:ddraw:IDirectDrawImpl_QueryInterface (0x16e0c0) The App is requesting a D3D device, but a non-OpenGL surface type was choosen. Prepare for trouble!
err:ddraw:IDirectDrawImpl_QueryInterface  (0x16e0c0) You may want to contact wine-devel for help
err:ddraw:IDirectDrawSurfaceImpl_QueryInterface No interface

err:d3d_surface:d3dfmt_convert_surface Unsupported conversation type 9

fixme:d3d_surface:IWineGDISurfaceImpl_Blt Can't handle DDBLT_WAIT flag right now.
fixme:ddraw:IDirectDrawImpl_SetCooperativeLevel (0x16e0c0)->((nil),00000008)
fixme:d3d:IWineD3DStateBlockImpl_Release Releasing primary stateblock

--------------------------------------------------------------

raden "err:d3d_surface:d3dfmt_convert_surface Unsupported conversation type 9" står flera gånger, säkert uppemot 100 rader.

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

muchas bild

Har du testat att söka? Nåja här har du något som kan funka:
http://www.winehq.org/pipermail/wine-bugs/2006-July/033235.html

hooloovoos bild

Har jag fått för mig eller är det att föredra att lägga windows program i wine mappen som förmodligen ligger i ~/.wine
-------------------
Duru - dummm

------------------- Duru - dummm

Marcuss bild

Har för mig att tibia uppdaterade sin linuxklient så den ska fungera utmärkt för senaste versionen. Pröva att ladda ner den!


p3rras bild

Förresten kanske ämnet borde flyttas till spel?

---------------- Ohne Fleiss, kein Preiss!

p3rras bild

Tyvärr hjälpte det varken att lägga tibia i wine mappen eller skriva till engine 0 efter Sad

---------------- Ohne Fleiss, kein Preiss!

Kristians bild

Kör winecfg och gå in på videoinställningarna - välj skapa virtuellt skrivbord, lämpligtvis 800x600 eller liknande, spara och försök starta spelet igen.

----------------------------------
where my .emacs is, that's my home

---------------------------------------

 

p3rras bild

Hej! Igen det var ett tag sedan!
Ja de har ju släppt en klient för Linux men den funkar inte heller. Såhär står det:

perra@perraslaptop:~/Desktop/Tibia$ ./Tibia
X Error of failed request: GLXUnsupportedPrivateRequest
Major opcode of failed request: 143 (GLX)
Minor opcode of failed request: 16 (X_GLXVendorPrivate)
Serial number of failed request: 58
Current serial number in output stream: 59
perra@perraslaptop:~/Desktop/Tibia$

Vad kan det vara?

---------------- Ohne Fleiss, kein Preiss!

p3rras bild

Tack det funkar inte än men ett litet steg på vägen!

Nu ser skärmen ut såhär:

http://www.gunnesgard.se/per/tibia.png

Och i terminalen kommer detta upp hela tiden:

fixme:d3d:IWineD3DSwapChainImpl_Present Unhandled present options 0xa05e04/(nil)
fixme:d3d_surface:IWineD3DSurfaceImpl_LoadTexture >>>>>>>>>>>>>>>>> 501 from glCopyTexImage2D @ surface.c / 1862
fixme:d3d_surface:IWineD3DSurfaceImpl_LoadTexture >>>>>>>>>>>>>>>>> 501 from glCopyTexImage2D @ surface.c / 1862

---------------- Ohne Fleiss, kein Preiss!

znarkens bild

För mig fungerade linuxklienten iaf
Kör ubuntu 7.04 med hårdvaruaccelererat nvidia kort.
Är du säker på har drivrutiner för ati/nvidia installerade och att de fungerar korrekt?
Det står bland linuxklientens systemkrav att det krävs.

mantonos bild

Vilken version av wine kör du? Om det inte är en utav dem senare måste du lägga till flaggan opengl efter.
wine -opengl .wine/min/väg/till/tibia.exe

----------------------------
Öppna format

----------------------------

Öppna format

p3rras bild

Ja det är det nog. Har tankat hem drivrutiner nu men när jag ska installera så funkar det inte.

Det verkade inte gå att posta så mycket men gå in på:
http://www.gunnesgard.se/per/fel.txt

---------------- Ohne Fleiss, kein Preiss!

p3rras bild

Ja det är det nog. Har tankat hem drivrutiner nu men när jag ska installera så funkar det inte. Skriver allt nu för säkerhets skull:
.
.
.
----------------------------------------------------
perra@perraslaptop:~/Desktop/dripkg$ sudo ./install.sh

DIRECT RENDERING OPEN SOURCE PROJECT - DRIVER INSTALLATION SCRIPT

[ http://dri.sourceforge.net ]

==========================================================================

Welcome to the DRI Driver Installation Script

The package you downloaded is for the following driver:

Driver Name : gdg
Description : Intel 830M/845G/852GM/855GM/865G/915G Driver
Architecture : I386
Build Date : 20040604
Kernel Module : gdg

Optional Information

Driver Version :
Special Description :

Press ENTER to continue or CTRL-C to exit.

DIRECT RENDERING OPEN SOURCE PROJECT - DRIVER INSTALLATION SCRIPT

[ http://dri.sourceforge.net ]

==========================================================================

Select from the following options:

1. Install driver (default)
2. Uninstall driver

Enter reponse [1-2], or CTRL-C to exit
1
get_osname()

DIRECT RENDERING OPEN SOURCE PROJECT - DRIVER INSTALLATION SCRIPT

[ http://dri.sourceforge.net ]

==========================================================================

The script will now compile the agpgart module and DRM kernel modules
for your machine.

Press ENTER to continue or CTRL-C to exit.

Compiling new agpgart module...

ERROR: AGPGART module did not compile

Compiling DRM module...

ERROR: Kernel modules did not compile

The DRI drivers can not be installed without the latest kernel modules.
Installation will be aborted. See the dri.log file for information on
what went wrong.

perra@perraslaptop:~/Desktop/dripkg$

-------------------------------------------------------------
INNUTI DRI.LOG-filen:
-----------------------------------------------------------

make -C /lib/modules/2.6.20-16-generic/build SUBDIRS=/home/perra/Desktop/dripkg/agpgart-2.0 modules
make[1]: Entering directory `/usr/src/linux-headers-2.6.20-16-generic'
CC [M] /home/perra/Desktop/dripkg/agpgart-2.0/backend.o
/home/perra/Desktop/dripkg/agpgart-2.0/backend.c:69: fel: motstridiga typer på "agp_backend_acquire"
include/linux/agp_backend.h:110: fel: tidigare deklaration av "agp_backend_acquire" var här
/home/perra/Desktop/dripkg/agpgart-2.0/backend.c:77: fel: motstridiga typer på "agp_backend_acquire"
include/linux/agp_backend.h:110: fel: tidigare deklaration av "agp_backend_acquire" var här
/home/perra/Desktop/dripkg/agpgart-2.0/backend.c:89: fel: motstridiga typer på "agp_backend_release"
include/linux/agp_backend.h:111: fel: tidigare deklaration av "agp_backend_release" var här
/home/perra/Desktop/dripkg/agpgart-2.0/backend.c:93: fel: motstridiga typer på "agp_backend_release"
include/linux/agp_backend.h:111: fel: tidigare deklaration av "agp_backend_release" var här
/home/perra/Desktop/dripkg/agpgart-2.0/backend.c:220: fel: expected "=", ",", ";", "asm" or "__attribute__" before "drm_agp"
/home/perra/Desktop/dripkg/agpgart-2.0/backend.c: I funktion "agp_add_bridge":
/home/perra/Desktop/dripkg/agpgart-2.0/backend.c:281: varning: implicit deklaration av funktionen "inter_module_register"
/home/perra/Desktop/dripkg/agpgart-2.0/backend.c:281: fel: "drm_agp" är odeklarerad (första förekomsten i denna funktion)
/home/perra/Desktop/dripkg/agpgart-2.0/backend.c:281: fel: (Varje odeklarerad identifierare rapporteras bara en gång
/home/perra/Desktop/dripkg/agpgart-2.0/backend.c:281: fel: för varje funktion den finns i.)
/home/perra/Desktop/dripkg/agpgart-2.0/backend.c: I funktion "agp_remove_bridge":
/home/perra/Desktop/dripkg/agpgart-2.0/backend.c:301: varning: implicit deklaration av funktionen "inter_module_unregister"
make[2]: *** [/home/perra/Desktop/dripkg/agpgart-2.0/backend.o] Fel 1
make[1]: *** [_module_/home/perra/Desktop/dripkg/agpgart-2.0] Fel 2
make[1]: Leaving directory `/usr/src/linux-headers-2.6.20-16-generic'
make: *** [default] Fel 2
make -f Makefile.linux DRM_MODULES=gdg.ko modules
make[1]: Entering directory `/home/perra/Desktop/dripkg/drm'
make -C /lib/modules/2.6.20-16-generic/build SUBDIRS=`pwd` DRMSRCDIR=`pwd` modules
make[2]: Entering directory `/usr/src/linux-headers-2.6.20-16-generic'
rm: kan inte ta bort "/home/perra/Desktop/dripkg/drm/.tmp_versions/CVS": Är en katalog
make[2]: *** [crmodverdir] Fel 1
make[2]: Leaving directory `/usr/src/linux-headers-2.6.20-16-generic'
make[1]: *** [modules] Fel 2
make[1]: Leaving directory `/home/perra/Desktop/dripkg/drm'
make: *** [gdg.ko] Fel 2

---------------- Ohne Fleiss, kein Preiss!

p3rras bild

Hmm, att ha flaggan opengl verkar inte funka, det verkar vara rätt knasigt:

root@perra-laptop:~/.wine/tibia# wine -opengl Tibia.exe
wine: could not load L"c:\\windows\\system32\\-opengl.exe": Module not found

-Det verkar som om jag har wine 0.9.22, ska prova att ladda ner den nyaste versionen...

Hmm..försökte uppdatera wine nu men detta var vad som hände:

perra@perra-laptop:~$ sudo apt-get install wine
Läser paketlistor... Färdig
Bygger beroendeträd
Reading state information... Färdig
wine är redan den senaste versionen.
0 uppgraderade, 0 nyinstallerade, 0 att ta bort och 0 ej uppgraderade.

---------------- Ohne Fleiss, kein Preiss!

znarkens bild

Du kör väl Ubuntu 7.04?
För isåfall räcker det väl med att gå in i "restricted modules" eller vad det nu heter på admin menyn och välja till drivrutiner?
Så var det för mig med Nvidias drivrutiner iaf.
Vad har du för märke på ditt grafikkort?

margus bild

Vet inte om det hjälper men jag tror att programnamnet skall komma före argumentet.
wine programn.exe -opengl

p3rras bild

Märke: Intel
Den finns inte med i listan över "proprietära drivrutiner"

---------------- Ohne Fleiss, kein Preiss!

p3rras bild

Det gick att starta spelet när man gjorde så men tyvärr kvarstår problemet... Sad

---------------- Ohne Fleiss, kein Preiss!

jonasbjorks bild

Det är för att Intel inte har prop drivare. De har öppna drivrutiner med 3D-accelaration.. NVidia och ATI i all ära, men Intel förstår det här med öppenhet.. http://www.intellinuxgraphics.org/

--
SUSE Linux
Jonas Björk - like.no.other
Now the mark is upon you, you just can't escape.

--
Jag är grundare av och administratör på Linuxportalen. Kontakta mig om du har frågor, funderingar eller synpunkter kring Linuxportalen.se .

p3rras bild

If you are not experienced doing this, we recommend that you get precompiled packages from one of the many Linux distributions.

Så står det på hemsidan men var hittar jag dem? kan man köra apt-get?

---------------- Ohne Fleiss, kein Preiss!

jonasbjorks bild

I den distribution jag kör installeras de automatiskt (ingår tydligen i Xorg). I min /etc/X11/xorg.conf står det Driver "i810"
.

--
SUSE Linux
Jonas Björk - like.no.other
Now the mark is upon you, you just can't escape.

--
Jag är grundare av och administratör på Linuxportalen. Kontakta mig om du har frågor, funderingar eller synpunkter kring Linuxportalen.se .

p3rras bild

Det verkar som om jag också har det installerat om jag nu skrivit in rätt paket:

perra@perraslaptop:~$ sudo apt-get install xserver-xorg-video-intel
Password:
Läser paketlistor... Färdig
Bygger beroendeträd
Läser in tillståndsinformation... Färdig
xserver-xorg-video-intel är redan den senaste versionen.
0 uppgraderade, 0 nyinstallerade, 0 att ta bort och 0 ej uppgraderade.
perra@perraslaptop:~$

---------------- Ohne Fleiss, kein Preiss!