Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

ÅÄÖ problem i open office eller i konqueror... (LÖST)

Hej.
Har följande problem:
När jag skriver ett dokument i Open Office och döper det till något med åäö i titeln döps det om, ex NÄL blir N%C4L.
Skapar jag en ny mapp och sparar dokumentet som NÄL blir både mappen och dokumentet omdöpt.
Även om jag sparar till en existerande mapp NÄL skapas en ny mapp kallad N%C4L och dokumentet läggs i den mappen
Detta är enorm irriterande och jag får gå in efteråt och döpa om och flytta dokument, det är inte så kul att skicka dokument till eventuella arbetsgivare där det står att man har datorvana och skickar filer med N%C4L som filnamn.
Så om någon kunde hjälpa mig att hitta den inställning som fixar detta vore jag tacksam.
Skulle åxå vilja ha hjälp med att se till att jag valt rätt kodning i Linux för Sverige.

Datorn är min IBM R59e med MEPIS 6.0

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

Kristians bild

Det är generellt en dålig ide att döpa filer med specialtecken som åäö i filnamnet - då texten tolkas olika på olika datorsystem. MacOSX, Ubuntu och de flesta andra distar kör utf-8,som är en smart lösning som både ger unicode-stöd och kompitabilitet med äldre program (så länge man håller sig inom de första 0-127 teckenkoderna).

http://en.wikipedia.org/wiki/UTF-8

----------------------------------
where my .emacs is, that's my home

---------------------------------------

 

magnusbergs bild

jag har själv haft samma problem och det var inte så roligt. Smile

Jag tror att lösningen är att precis som Kristian skriver köra hela systemet med utf-8. I alla fall upphörde mina problem när jag konverterade till det. Jag TROR det är så att vissa program som Open Office och Gimp kör utf-8 på filnamnen i en KDE miljö även om KDE miljön kör iso-8859-1.

Hur du byter teckenkodningsinställningar har jag ingen lätt tillgänlig länk på men när du löst det så kolla här hur du konverterar filnamnen. Convert file names to a different encoding with convmv.

norlins bild

Tackar ändring till utf-8 i KDE löste problemet
________________________________________________________
Min blogg
Hur kan man ha ont om tid, när det hela tiden kommer ny?
Linux user 439707

 

Hur kan man ha ont om tid, när det hela tiden kommer ny?