Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

Problem med ATI-drivrutiner i Mandriva Linux Free 2007

Jag har problem med att köra det grafiska gränsnittet i Mandriva Linux Free 2007. Vad jag vet så har Mandriv problem med att kunna köra med ATI-grafikkort, jag har en ATI Radeon X800GT. Men jag lyckades iallafall få igång det grafiska gränssnittet genom att använda drivrutinen Radeon(fgdev) i XFdrake. Men den ger en väldigt låg uppdateringsfrekvens så jag laddade ner de nyaste drivrutinerna från ATI:s hemsida och jag följde installationinstruktionerna som det stod. Men när jag var klar och skulle installera om systemet då får jag samma problem som det var fårn första början. Nämligen att den ger felmeddelandet "[EE] no device detected" och jag hamnar återigen på det textbaserade login-inställningen.

Hur kommer man runt problemet?

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

abergmans bild

Nan kan ju köra windows drivar i linux med programet nwdiswrapper jag tror att det var så det hette kan va ndiswrpper också.
------------


 

 

mhns bild

Om du redan har lagt till internet-repositories (vad nu de heter på svenska), från Easy-Urpmi så kan du installera det genom att skriva (som root) 'urpmi dkms-ati'.

Mer info finns på http://mandrivausers.org/ som är mer inriktad mot mandriva. På engelska dock, men där gör de i alla fall annat än bara tjatar om ubuntu och suse hela dagarna.

john13ths bild

Ok, nu hittade Mandriva paketet dkms-ati. Men när jag fick igång den fik jag det här meddelandet:


1- kernel-source-stripped-2.6.17.8mdv-1-1mdv2007.0.x86_64 : The source code of the Linux kernel stripped for post build (to install)
2- kernel-source-stripped-2.6.17.5mdv-1-1mdv2007.0.x86_64 : The source code of the Linux kernel stripped for post build (to install)
3- kernel-source-stripped-2.6.17.6mdv-1-1mdv2007.0.x86_64 : The source code of the Linux kernel stripped for post build (to install)
4- kernel-tmb-source-stripped-2.6.18.5-1mdv-1-1mdv2007.0.x86_64 : The stripped Linux source code for kernel-tmb-2.6.18.5-1mdv (to install)
5- kernel-linus-source-2.6.19.2-1mdv-1-1mdv2007.0.x86_64 : The source code for the Linux kernel (to install)
6- kernel-linus-source-2.6.19.1-1mdv-1-1mdv2007.0.x86_64 : The source code for the Linux kernel (to install)
7- kernel-source-2.6.17.8mdv-1-1mdv2007.0.x86_64 : The source code for the Linux kernel (to install)
8- kernel-linus-source-2.6.18.3-1mdv-1-1mdv2007.0.x86_64 : The source code for the Linux kernel (to install)
9- kernel-linus-source-stripped-2.6.19-3mdv-1-1mdv2007.0.x86_64 : The source code of the Linux kernel stripped for post build (to install)
10- kernel-multimedia-source-stripped-2.6.17.13-3mdv-1-1mdv2007.0.x86_64 : The stripped source code for the Linux kernel-multimedia-2.6.17.13-3mdv (to install)
11- kernel-linus-source-2.6.19.2-2mdv-1-1mdv2007.0.x86_64 : The source code for the Linux kernel (to install)
12- kernel-linus-source-stripped-2.6.19.2-1mdv-1-1mdv2007.0.x86_64 : The source code of the Linux kernel stripped for post build (to install)
13- kernel-tmb-source-stripped-2.6.17.13-4mdv-1-1mdv2007.0.x86_64 : The stripped Linux source code for kernel-tmb-2.6.17.13-4mdv (to install)
14- kernel-linus-source-stripped-2.6.19.2-2mdv-1-1mdv2007.0.x86_64 : The source code of the Linux kernel stripped for post build (to install)
15- kernel-source-2.6.17.5mdv-1-1mdv2007.0.x86_64 : The source code for the Linux kernel (to install)
16- kernel-linus-source-stripped-2.6.18.3-1mdv-1-1mdv2007.0.x86_64 : The source code of the Linux kernel stripped for post build (to install)
17- kernel-linus-source-stripped-2.6.19-2mdv-1-1mdv2007.0.x86_64 : The source code of the Linux kernel stripped for post build (to install)
18- kernel-linus-source-2.6.18.5-1mdv-1-1mdv2007.0.x86_64 : The source code for the Linux kernel (to install)
19- kernel-linus-source-stripped-2.6.18.rc7.1mdv-1-1mdv2007.0.x86_64 : The source code of the Linux kernel stripped for post build (to install)
20- kernel-linus-source-2.6.19.1-2mdv-1-1mdv2007.0.x86_64 : The source code for the Linux kernel (to install)
21- kernel-linus-source-2.6.19-2mdv-1-1mdv2007.0.x86_64 : The source code for the Linux kernel (to install)
22- kernel-tmb-source-2.6.18.5-1mdv-1-1mdv2007.0.x86_64 : The Linux source code for kernel-tmb-2.6.18.5-1mdv (to install)
23- kernel-tmb-source-2.6.17.13-4mdv-1-1mdv2007.0.x86_64 : The Linux source code for kernel-tmb-2.6.17.13-4mdv (to install)
24- kernel-linus-source-2.6.18.2-1mdv-1-1mdv2007.0.x86_64 : The source code for the Linux kernel (to install)
25- kernel-source-2.6.17.6mdv-1-1mdv2007.0.x86_64 : The source code for the Linux kernel (to install)
26- kernel-linus-source-stripped-2.6.19.1-1mdv-1-1mdv2007.0.x86_64 : The source code of the Linux kernel stripped for post build (to install)
27- kernel-multimedia-source-2.6.17.13-3mdv-1-1mdv2007.0.x86_64 : The source code for the Linux kernel-multimedia-2.6.17.13-3mdv (to install)
28- kernel-linus-source-stripped-2.6.19.1-2mdv-1-1mdv2007.0.x86_64 : The source code of the Linux kernel stripped for post build (to install)
29- kernel-linus-source-stripped-2.6.18.5-1mdv-1-1mdv2007.0.x86_64 : The source code of the Linux kernel stripped for post build (to install)
30- kernel-linus-source-2.6.18.rc7.1mdv-1-1mdv2007.0.x86_64 : The source code for the Linux kernel (to install)
31- kernel-linus-source-2.6.19-3mdv-1-1mdv2007.0.x86_64 : The source code for the Linux kernel (to install)
32- kernel-linus-source-stripped-2.6.18.2-1mdv-1-1mdv2007.0.x86_64 : The source code of the Linux kernel stripped for post build (to install)
Vad är ditt val? ( 1-32)

Vad ska jag välja för något?

john13ths bild

Nu har jag lyckats installera paketet och på sist i statusmeddelandet stod det två sätt hur man kunde konfigurera kortet,

Det ena var att köra XFdrake och markera drivrutinen Radeon(fglrx).

Det andra var att ändra i xorg.conf-filen där i rubriken Device man skulle ändra namnet på den aktuella drivrutinen man hade, till Radeon(fglrx) OCH sen köra något config-kommando efteråt som jag inte kommer ihåg vad det var.

Jag körde på det ena alternativet och valde Radeon(fglrx). Jag fick samma fel som det var från första början, nämligen "[EE] no device detected" :@. Men det är kanske så att man måste ha de senaste drivrutinerna från ATI:s hemsida installerade för att det ska fungera? Och hur konfigurerar man med det andra alternativet?

john13ths bild

Nu fick jag till det med grafikdrivrutinerna. Efter att jag lade in paketet så installerade jag återigen från början grafikdrivrutinerna från ATI:s hemsida och körde $ aticonfig --initial. Efter jag startade om datorn kunde jag få igång det grafiska gränsnittet och samtidigt som root och som vanliga användare kunde jag ha högre upplösning och samtidigt ha en hög uppdateringsfrekvens. Allt i frid och fröjd tills jag loggade ut från kontot så började plötsligt skärmen att slockna och jag kunde inte annat än att starta om datorn. När jag laddade om Mandriva igen då fick jag dock tillbaks det grafiska gränssnittet som det skulle vara och jag har fortfarande de önskade upplösningarna i alla konton. Men jag märkte också att inloggningsskärmen har inte alls samma upplösning och jag misstänker att den använder Radeon(fbdev)-drivrutinen som jag hade innan (fglrx)-drivrutinen och att skärmen blinkar till när jag loggar in på kontot och då ändrar den om till den önskade upplösningen. Och jag ser i xorg.conf-filen att i Device-sektionen att det står Radeon(fbdev) och på andra ställen står det aticonfig(fglrx). Hur åtgärdar man det problemet med inloggningsskärmen?

john13ths bild

Hmm, den kunde inte hitta ett paket som hette så när jag skrev

$ urpmi dkms-ati

Annan lösning?

mhns bild

http://mandrivausers.org/lofiversion/index.php/t37974.html

Skriv uname -r för att få reda på vilken kärnversion du har, sedan väljer du motsvarande kernel-source-stripped.

Använder du x86_64?

ein.anderssons bild

Ndis är bara för Nätverksenhet (nätverkskort, modem m.m.)
-
Jag är en spegel av den du tror jag är.

Denna text får användas enligt CCommons BY-ND 2.5 med undantag från att den inte får kopieras, sändas eller distribueras utan att informera mig

mhns bild

Det ska finnas något program som heter aticonfig eller nåt sånt har jag för mej

mhns bild

Jag har ingen som helst aning. Finns det ingen med lite ATI-erfarenhet på det här forumet?

mhns bild

Är du root när du skriver det?
$ menas att du är en vanlig användare?

Skriv 'su' (enter) och sen roots lösenord för att bli root (prompten ändras till #) sen ska du kunna installera med det kommandot (urpmi dkms-ati) om du gjort det som står på Easy-Urpmi.

Jag har själv inget ati-kort så jag vet inte så noga, men som jag har fattat det ska man kunna använda det paketet.

# urpmq -i dkms-ati
Name        : dkms-ati
Version     : 8.28.8
Release     : 3plf2007.0
Group       : System/Kernel and hardware
Size        : 2037821                      Architecture: i586
Source RPM  : ati-8.28.8-3plf2007.0.src.rpm   Build Host: kone.onse.fi
Packager    : Anssi Hannula <anssi@zarb.org>
URL         : http://www.ati.com/support/driver.html
Summary
     : ATI kernel module for Radeon 8500 and newer ATI video cards
Description :
ATI proprietary kernel module for ATI Radeon 8500 and newer ATI
video cards. This is to be used with the ati package.

This package is in PLF for its non-free license.

Ta en titt på mandrivausers.org annars, sökfunktionen är inte så bra där, men det är ju bara att göra en ny tråd, där får du garanterat hjälp.

john13ths bild

Ja, jag har x86_64. När jag skrev uname -r stod det

2.6.17-5mdv. Men hela det namnet stod inte med på listan. Det närmaste jag kunde komma på listan var nummer

2- kernel-source-stripped-2.6.17.5mdv-1-1mdv2007.0.x86_64

Ska jag ta den?

lundatoks bild

Känner inte igen problemet, den gör inte så på min laptop. Kan man välja om inställningarna ska gälla en viss användare eller gälla för hela systemet i ATI:s konfigurering?

--
MöLUG
Svenska OSS-bloggar

mhns bild

ja, kör på den

mhns bild

många skulle nog svara att det bara är onödigt att använda 64-bits OS även om processorn är en sådan, man vinner inte mycket hastighet och många program fungerar inte för 64 ännu, bla flash.
(jag vet att jag gör mycket reklam för dem men..., Going from 32 to 64 bits)