Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

Grub problem

Jag skulle installera opensuse (10.Innocent på en dator (dualboot med XP), av någon anledning så strulade grub till det hela. Jag får bara upp en prompt med texten "grub >", där vet jag inte vad jag ska göra. Tyvärr så startar verken XP eller Suse, problemet uppstod vid initialuppstarten (heter det så?). Suse blev alltså inte ens färdig installerat och en bootloader borde inte vara installerad i detta stadie.

Jag provade den enkla lösningen att återställa XP från XPs CD, för att sedan göra ett nytt försök med Suse. Samma problem.

Är det någon som har koll på vilka argument man kan ge grub för att komma vidare?

//Fredrik

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

lundatoks bild

abergmans bild

Jag tror att du bör försöka dig på att ställa in Grub förhand. det är riktigt enkelt. läs i Gentoo's handbok, där står allt. för att komma åt grib.conf filen s rekomenderar jag en Live-CD gentoos är lite och smidig, Ubunutus funkar kanon.
--------------


 

 

sundmarks bild

Den enda gången jag har råkat ut för detta med Grub-problem, är när det är en äldre bios-version installerad. Prova att installera en aktuell bios från din datorleverantör och gör sedan en omstart. Det löste mitt problem på en äldre dator.

Datorn med äldre Bios stannade med en Grub> prompt och efter uppdatering av Bios startade den fint.
--

Mikael Sundmark

 

Mikael Sundmark

mauths bild

GRUB manual om det är till någon hjälp
GRUB manual

- "Den nyttigaste läxa livet lärt mig är att idioterna många gånger har rätt." Winston Churchill

delhages bild

Av någon anledning så har inte grubs konfigurationsfil installerats (/boot/grub/menu.lst), det är därför du får grub-prompten.

Du kan skriva kommandon där för att starta SUSE eller XP. Vet du vilken partition som är /boot? Om vi antar att den är hda1 så kan du skriva följande vid prompten:

grub> root (hd0,Innocent
grub> kernel /vm<TAB>
grub> initrd /initrd<TAB>

där <TAB> betyder att du trycker tab-tangenten. Grub har, precis som bash, tab-komplettering.

Då du väl kommit in i systemet måste du också fixa en konfigurationsfil. Läs grubdokumentationen om hur du gör det.

Grundproblemet, varför detta inte gjordes automatiskt, vet jag inte, det är väldigt konstigt.

Mvh
Lasse
RHC{E,X,A,SS} CL{P,E} CNI LPIC-2
GnuPG ID: 569492FE

RHC{E,X,A,SS} CL{P,E} CNI LPIC-2 GnuPG ID: 569492FE

fredrikperssons bild

Nu har jag avancerat nu får jag "error 18", nu har jag iaf något att googla på Smile

Men det är ändå mysko, datorn körde OpenSuSE 10.0 utan att gnälla, det är bara en ominstallation på ny hårddisk.

----------------------------------------------------
Jag faller för grupptrycket....
MöLUG - Svenska OSS-bloggar
Fredrik Persson

 

//Fredrik Persson

pcfixarens bild

Jag hade samma problem när jag försökte få sled10 att dualboota med ubuntu
den slutförde aldrig installationen utan jag fick upp ett felmeddelande med grub error 17
jag hade ubuntu på hda och slulle lägga in sled10 på hdb och jag provade säkert fem gånger men samma fel hela tiden varje installation tog ungefär en timme
när jag till slut plockade bort ubuntu och provade installera sled10 på hda så gick det att installera och jag provade sled10 ett par dar men det krånglade när jag skulle uppdatera det för man var tvungen att ha en kod från suses hemsida och jag fick inte det att fungera först men till slut gick det
uppdateringarna tog betydligt längre tid än ubuntus sen var det en del andra saker som krånglade till det
jag skulle bla lägga in opengl drivare för nvidia med då slutade x att starta så jag installerade ubuntu igen och det fungerar iallafall
_______________

I Windows kan du göra allt det som Microsoft låter dig göra, i Linux kan du göra allting din dator klarar av att göra"

_____________________________________________________________________ Köp din Ubuntu-dator hos: http://ggsdata.se , http://compless.se, http://www.effbe.se http://www.ferni.se

Ubuntuforum på svenska www.ubuntu-se.org