Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

Långsam bios [LÖST]

Har Winxp samt Zenwalk installerat på min Hp nx6325 och allt fungerar klockrent. Dock så beteer sig bios annorlunda beroende vilket OS jag kör en omstart ifrån. När jag bootar om datorn ifrån Winxp så startar biosen om snabbt och man hinner knappt se F-tangenterna man skall använda för att ta sig in i bios. Men när jag bootar om ifrån Zenwalk så blir biosen väldigt långsam och det tar länge innan ens HP loggan kommer upp och F-tangent valet stannar kvar länge innan Grub kommer upp.

Är detta någon fler har råkat ut för ?

Är det något Zenwalk specifikt ? (Har ännu inte provat någon annan dist på denna dator).

// Eric

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

darus bild

Har liknande grej på min IBM Thinkpad T30 med Slackware. Har inte gjort några eftersökningar men vill minnas de inte inträffade med 2.4 kärnan utan kom efter jag kompilerat en 2.6 kärna. Så antar de är kärnspecifikt och att det finns nått ändra där. Har dock inte tagit mig tid att ordna det än... bara haft den i 1,5 år. :/

emos bild

Är inte Grub jag använder, utan Lilo. Skall kolla in det där angående 2.6 kernel + bios problem. Har googlat lite men inte hittat något vettigt hitills.

emos bild

This notebook is affected like many of the Hp Compaq notebooks by the "bad state" problem (the system after linux shutdown or reboot is slow booting bios, keyboard often don't work, processor fixed to at maximum 1.33ghz). To reset the bad state, it's necessary to remove ac power and battery.

The cause of this problem is in the psmouse module and its interaction with the bios (I don't know if it's a bios bug or psmouse driver bug). A solution is to compile psmouse as module and unload it before shutdown or reboot.

Hittade följande efter mycket letande på google, skall se vad jag kan göra åt det. (Ursäkta om jag inte översatte texten)

// Eric

emos bild

Det var psmouse + bios som inte ville lira med varandra.
Lösningen är att köra modprobe -r psmouse före boot/halt.
Så det första man måste göra är att ändra så att psmouse är Module i sin kernel.

Lägg därefter in /sbin/modprobe -r psmouse i rc.0
och /sbin/modprobe -i psmouse i din rc.local.

// Eric

iaidokas bild

Fy katten vilket snårigt problem det måste ha varit att felsöka första gången. Sad

---
"Linux är så kallad slackware, gratis, det bara
ligger och väntar på dig ute i cyberspace."
- Geir Nielsen

Test.

darus bild

Oj, inte var dag problemen löser sig själv om man väntar tillräckligt länge. Snyggt jobbat! Smile