Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

Ny version av Puppy-Exton med skrivbordsmiljön Xfce4.4

Puppy-Exton Xfce 2007 är baserad på Puppy Linux 2.14. Den nya versionen har har bl a ökat stöd för trådlösa nätverkskort. Kernel 2.6.18 används. Puppy-Exton Xfce 2007 använder Xfce4.4 som skrivbordsgränssnitt istället för Fvwm95 (som är standard i Puppy Linux). Systemet körs ändå lika snabbt som originalet, vilket betyder att det går otroooligt snabbt (jämfört med de flesta andra OS). Xfce4.4 är på svenska liksom systemspråket. Dessutom bl a följande program: Gimp 2.3.14 (senaste utvecklingsversion av "photoshopdödaren"), AbiWord 2.4.6 (senaste version), Opera 9.10 (senaste version), GParted (partitioneringsprogram) och Gxine (multimediaspelare). Övrigt: NTFS-skrivbarhet och tillgång till "alla" win32-codecs. Puppy-Exton Xfce 2007 är en unik dist. D v s såvitt jag vet finns det ingen puppyversion någonstans i hela vida världen (för nerladdning], som innehåller Xfce4.4. Det beror (sannolikt) på att Xfce4.4 inte är alldeles lätt att installera i Puppy Linux. Se en skärmdump av Puppy-Extons skrivbord HÄR. Läs mera HÄR.

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

jensos bild

OBS! Kernel 2.6.18 ska inte användas. Det finns en elak bugg.
Det rapporterades före jul.
http://lkml.org/lkml/2006/12/18/56
http://kerneltrap.org/node/7504
Den uppmärksammades först av libTorrent/rTorrent.
http://rakshasa.no/pipermail/libtorrent-devel/2006-December/000993.html
Ingen kernel äldre, än 2.6.20 bör användas. Framför allt om man har ext3 som filsystem.

/Jens
---
Registered User # 259689 http://counter.li.org
Aw come on .... Joe is a Microsoft guy, and is probably having GUI
withdrawal.
You don't expect him to quit cold turkey do you?

---

Registered User # 259689 http://counter.li.org

Aw come on .... Joe is a Microsoft guy, and is probably having GUI withdrawal. You don't expect him to quit cold turkey do you?

extons bild

LINUX.EXTON.NET - Boot- och körbara linuxskivor på svenska
jenso!
Det berör näppeligen Puppy Linux m fl "etablerade" linuxsystem.

LINUX.EXTON.NET

jensos bild

Så vadå? Är Linus Torvalds inte en etablerad kernel hacker?
http://lkml.org/lkml/2006/12/31/122

The big thing at least for me personally is that nasty shared mmap
corruption fix

Oavsätt vad. Lanserar man inte en distribution, när en sådan risk föreligger.
Sedan får du och Puppy, tycka vad ni vill. I synnerhet, när det finns nyare kärnor att använda. Sedan några månader bakåt.
Och det har inget med *etablerade* system att göra. En bugg är en bugg.

/Jens
---
Registered User # 259689 http://counter.li.org
Aw come on .... Joe is a Microsoft guy, and is probably having GUI
withdrawal.
You don't expect him to quit cold turkey do you?

---

Registered User # 259689 http://counter.li.org

Aw come on .... Joe is a Microsoft guy, and is probably having GUI withdrawal. You don't expect him to quit cold turkey do you?

extons bild

LINUX.EXTON.NET - Boot- och körbara linuxskivor på svenska
jenso!
Utan att utreda saken närmare befarar jag att du inte riktigt vet vad du talar om. Barry Kauler - mannen bakom Puppy Linux - är ett datageni. Skulle han släppa en dist/kernel med allvarliga fel? Inte sannolikt. Dessutom finns det massor med (seriösa) linuxdistar innehållande kernel 2.6.18 (openSuSE 10.2 t. ex.) och "lägre". Det fel du "varnar" för måste antingen vara åtgärdat (patch?) eller också vara av helt ofarligt slag. De länkar du hänvisar till ger f ö inte klart besked om vari felet består. Kan du upplysa mig/oss?

LINUX.EXTON.NET

jensos bild

Det lär finnas patchar, för äldre kärnor. Men vad jag känner till.
Så ska den finnas tidigast i 2.6.19.2. Annars är det 2.6.20-rc3.
Finns inlägg om den saken. http://bbs.linux.se/viewtopic.php?t=34396
Det ska vara mmap och vm. http://lkml.org/lkml/2006/12/29/26
Även reiserfs kan spöka. http://www.uwsg.iu.edu/hypermail/linux/kernel/0612.3/0307.html
"A nasty file corruption bug - fixed"
http://lwn.net/Articles/215868/
Ska även kunna påverka databaser.
Sedan får de som kan den saken (mmap, vm, ext3, reiserfs), gärna förklara på ett bättre sätt.
Finns patchen i Puppy? Det vet inte jag. Det jag har gjort, är att peka på problemet.
Så varför just du inte känner till buggen, vet inte jag. Den är mer än välpublicerad.

/Jens
---
Registered User # 259689 http://counter.li.org
Aw come on .... Joe is a Microsoft guy, and is probably having GUI
withdrawal.
You don't expect him to quit cold turkey do you?

---

Registered User # 259689 http://counter.li.org

Aw come on .... Joe is a Microsoft guy, and is probably having GUI withdrawal. You don't expect him to quit cold turkey do you?

extons bild

LINUX.EXTON.NET - Boot- och körbara linuxskivor på svenska
jenso!
Jag förstår fortfarande inte vad du pratar om (och det gör du nog inte själv heller). Alla stora linuxdistributörer som t. ex. Slackware, Red Hat, Mandriva, SuSE, openSuSE, KNOPPIX, DSL, Puppy Linux m fl (som alla levererar linuxsystem med kernel 2.6.18) skulle alltså med berått mod utsätta användarna för risker/buggar? Männen bakom DSL skulle vara särskilt hänsynslösa, eftersom den disten fortfarande använder kernel 2.4. För du menar tydligen (på fullt allvar?) att alla distar med en lägre kernelnversion än 2.6.19.2 är "felaktiga". Jag orkar inte forska i saken, men allt tyder på att du missförstått det hela. Grovt.

LINUX.EXTON.NET

jensos bild

Varför inte just efterforska. Genom att läsa vad som står, på de angivna länkarna?
Slackware 11 lanserades i September förra året. 2.6 kärnorna i Slackware.
Ligger i extra och testing. Du installerar dom således, på eget bevåg.
Default är 2.4.33.3. Det är i huvudsak 2.6 serien, det är frågan om.
Att kunna uppgradera, på egen hand. Är ganska givet.
Kernelbuggen blev känd i December och fixen, lanserades på nyårsafton.
Nu är det Mars. Varför använda en kärna med en känd bugg?
Ingen av de kommentarer, jag har läst. Tar lätt på saken.
Linus Torvalds tog inte lätt på saken. Det klassades som en mycket allvarlig bugg.
Så jag tror knappast att jag överdriver, när det finns de som drabbas.
Vilket även länkarna påvisar.
Använder förnärvarande, ingen av de övriga stora distarna. Förutom Slackware. Så vet ej,
vilka patchar/upgraderingar de haft.

/Jens
---
Registered User # 259689 http://counter.li.org
Aw come on .... Joe is a Microsoft guy, and is probably having GUI
withdrawal.
You don't expect him to quit cold turkey do you?

---

Registered User # 259689 http://counter.li.org

Aw come on .... Joe is a Microsoft guy, and is probably having GUI withdrawal. You don't expect him to quit cold turkey do you?

extons bild

LINUX.EXTON.NET - Boot- och körbara linuxskivor på svenska
jenso!
Jag tittade faktiskt lite på de röriga inlägg du hänvisar till. Det framkom bl a att vissa menar att buggen tillkom i kernelversioner s e n a r e än 2.6.18. Ändå: Ditt (seriösa) råd till alla är alltså att sluta köra linuxsystem med en tidigare kernel än 2.6.20? Med denna fråga/konstaterande är denna "debatt" avslutad för min del. F ö: Du bör fundera på ordspråket "Det dunkelt sagda är det dunkelt tänkta".

LINUX.EXTON.NET

jensos bild


Det framkom bl a att vissa menar att buggen tillkom i kernelversioner s e n a r e än 2.6.18.

Visst. Som i alla diskussioner, finns det olika uppfattningar. Men det var libTorrent/rTorrent och 2.6.18 som utlöste den.
Den kan ha funnits så tidigt, som i 2.5 serien. Så varför ta onödiga risker. När det finns kärnor, vilka har buggfixen?


Ditt (seriösa) råd till alla är alltså att sluta köra linuxsystem med en tidigare kernel än 2.6.20?

Vem har sagt det?
Det går alldeles utmärkt, att upgradera till en nyare version. Om distron inte tillhandahåller en patch/upgradering.
Annars kan man alltid undvika allt sådant, som riskerar utlösa buggen.
Felet med din Puppyversion, är att den tillsynes. Inte är upgraderad/patchad, för den elaka buggen.
Samt att du inte hade koll på det. Informationen har ju funnits, sedan i December förra året.
Det borde således, ha gått alldeles utmärkt. Att byta till en nyare version, om Puppy inte har en patchad version.
Personligen har jag valt, att patcha/upgradera själv.
Kör för närvarande, 2.6.20-ck1 (laptop, Slackware 11.Innocent, 2.6.20.3 (server, Slackware 11.Innocent och en annan.
Vilken ska upgraderas till, 2.6.21-rc4 eller nyare (testbänk, CRUX 2.2, kanske gå för 2.3 trädet).
Tillåter inte distron ett sådant förfarande, då kan det vara dags att byta till en mer tillåtande.
Om den inte tillhandahåller, en upgradering/patch. Sedan är det upp till var och en.


Du bör fundera på ordspråket "Det dunkelt sagda är det dunkelt tänkta".

Vadå?
Är det fel av mig, till att peka på ett visst förhållande.
Eller varför ska jag vara tyst, om den saken. När det föreligger en uppenbar, dokumenterad risk?
Tala i så fall om för mig, varför jag ska vara tyst. Om den saken.

/Jens
---
Registered User # 259689 http://counter.li.org
Aw come on .... Joe is a Microsoft guy, and is probably having GUI
withdrawal.
You don't expect him to quit cold turkey do you?

---

Registered User # 259689 http://counter.li.org

Aw come on .... Joe is a Microsoft guy, and is probably having GUI withdrawal. You don't expect him to quit cold turkey do you?

extons bild

LINUX.EXTON.NET - Boot- och körbara linuxskivor på svenska
jenso!
Ordspråket i mitt förra inlägg betyder inte riktigt det du tror.

LINUX.EXTON.NET