Välkommen till linuxportalen.se!

Linuxportalen.se är Sveriges största och aktivaste webbplats för användare av öppen- och fri programvara.

Du besöker Linuxportalen.se som gäst vilket begränsar din möjlighet att använda webbplatsens alla funktioner. Genom att registera dig som medlem får du inte bara möjlighet att söka bland webbplatsens innehåll, skapa nya och delta i befintliga diskussioner, skapa din egen blogg, kommunicera med andra medlemmar genom privata meddelanden och delta i omröstningar. Du får också tillgång till Veckans Kadavro - en seriestrip unikt skapad för Linuxportalen.se!

Registeringen sker snabbt och är helt kostnadsfri - tveka inte, bli medlem idag!

Installera rpm i Debian, hur göra?

Hej, jag undrar hur man gör för att installera ett rpm paket i debian.
Tackar för all hjälp jag kan få

/Karlgus

Alternativ för kommentarvisning

Välj ditt önskade sätt att visa kommentarerna och klicka på "Spara" för att verkställa dina ändringar.

mikaeljs bild

RPM är för redhatbaserade distributioner. Det går att konvertera rpm till deb med alien men det är inte att rekommendera. Vad är det för program du försöker installera? Man kanske kan leta upp en debianversion av paketet...



 



~~~ Have a goodyear - http://www.youtube.com/watch?v=tO2wb-LarfU ~~~

 

mikaeljs bild

Om paketet/programmet bara finns som rpm så finns det en guide som du kan följa:
http://www.debianadmin.com/install-rpm-files-in-debian-and-ubuntu.html



 



~~~ Have a goodyear - http://www.youtube.com/watch?v=tO2wb-LarfU ~~~

 

karlguss bild

Tack för alla svar och den hjälp jag har fått hitills!
Jag tänker nog skriva ett mail till de som gjort programmet och fråga om det går att lösa.
Jag återkommer senare med vad de har sagt och hur det har gått för mig.

/Karlgus

fredentofts bild

Google "marratech linux" gav mig följande:
http://www.marratech.com/forum/lofiversion/index.php/t1725.html
Kanske kan vara nåt även om det inte är helt färska uppgifter.
 
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Argumentera aldrig med idioter.
De drar bara ner dig till sin nivå och vinner på erfarenhet!

-
För övrigt anser jag att trådindenteringen måste lagas
-
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-

karlguss bild

Det är programmet marratech som används till distanskursen...
Har kört alien och packat upp det genom dpkg -i...
så långt har allting gått bra men när jag går in i mappen som blir och startar programmet via mappen bin, så stannar den efter ca 1/4 installationen.
Någon som vet en lösning på detta eller är det bara att vänta?

mikaeljs bild

Testade programmet själv...
Först så körde jag alien för att göra ett debpaket. Sen dpkg -i för att installera Marratechprogrammet. Allt dit går bra. Sen går jag till mappen och kör ./Marratech och programmet börjar att starta men det stoppar vid en fjärdedel. Har inte hittat nåt felmeddelande än, skall se om jag får fram nåt. Nånting gör i alla fall att programmet inte kan starta upp. Det är lite detta som gör att man blir irriterad över att det skall vara grafiska lösningar. En verbosetext i terminalen och man ser var felen uppstår... :/



 



~~~ Have a goodyear - http://www.youtube.com/watch?v=tO2wb-LarfU ~~~

 

mikaeljs bild

ajdå, ser att det är kodat i java Sad
kanske nån javakodare som kan hjälpa till med lite grävande... annars får du nog prata med utvecklarna...



 



~~~ Have a goodyear - http://www.youtube.com/watch?v=tO2wb-LarfU ~~~

 

fedors bild

Har nu försökt installera samma program på ubuntu 8.04 får samma problem.
TIps på felsökningar?

hateballs bild

Jag testade just i Ubuntu 7.10 med JRE5, och det var inga problem alls. Är det möjligen så att ni kör JRE6?

fedors bild

JREn följer  med programet så det borde inte spela någon roll.